MySQL、fail2ban 和许多其他服务器应用程序将其数据存储在 /var/lib 中。
他们使用正确的目录吗?
如果是这样,为什么它被命名为 lib,这意味着库?
我有两台机器,“发送器”和“接收器”。
发送者每晚运行以下命令:
zfs send -i bpool/backups@2018-09-04 bpool/backups@2018-09-05 | ssh receiver /sbin/zfs receive bpool/backups
Run Code Online (Sandbox Code Playgroud)
将最新的 bpool/备份从发送方发送到接收方。(日期每晚自动生成。)
如果某人(在接收器上)只做以下事情:
cd /bpool/backups
ls
Run Code Online (Sandbox Code Playgroud)
它破坏了夜间备份作业,并出现以下错误:
root@sender:~# zfs send -i bpool/backups@2018-09-04 bpool/backups@2018-09-05 | ssh recevier /sbin/zfs receive bpool/backups
cannot receive incremental stream: destination bpool/backups has been modified
since most recent snapshot
warning: cannot send 'bpool/backups@2018-09-04': Broken pipe
Run Code Online (Sandbox Code Playgroud)
(我认为这是因为更新了 atime,或类似的原因。)
我怎样才能阻止这种情况发生?(如果我将receiver:/bpool/backups 设置为只读,接收将如何工作?)
我如何指示 MySQL 完成所有“进行中”事务,但延迟启动新事务(而不启动客户端),直到我拍摄了 ZFS 或 LVM 快照(这需要不到一秒钟)。
例如
第一步不应该导致客户端错误,只是在到达第 4 步之前的一个非常短的暂停。
是否有可以执行 1 和 4 的 MySQL 命令?这些是什么?
我想使用 rsync-over-ssh 将备份从许多远程目标机器拉到中央备份。
我可以以 root 用户身份执行此操作,但这会让我意外地运行错误的 rsync 命令,该命令会写入应备份的计算机或从中删除。
是否可以在目标计算机上设置只读 root 用户?
rsync 命令需要能够读取目标计算机上的任何文件,但不能写入。
有没有办法制作一个 Linux 块设备,它只是一个现有块设备的偏移量?
ie/dev/sdo的块 0 是/dev/sda块 100,/dev/sdo因此比 小 100 个块/dev/sda。
我正在使用 ext4 加密。 https://wiki.archlinux.org/index.php/Ext4#Using_file-based_encryption
在解密目录之前,我可以在其中看到许多加密的文件名。
我想复制加密的文件,以便我可以在不同的机器上解密它们。
我可以用 ecryptfs 做到这一点。我如何使用 ext4 加密来做到这一点。
我有两个大文件。
a.qcow2 是 16GB。
b.qcow2 是 17GB。
的前 16GB 与b.qcow295% 相同a.qcow2。
哪些 Linux 命令可以让我生成两个文件之间的增量?(大小应小于 2GB。)
什么 linux 命令可以让我应用 deltaa.qcow2来产生与 相同的输出b.qcow2?
delta 格式是否有安全措施,例如源和目标大小和散列?
linux ×2
zfs ×2
block-device ×1
ecryptfs ×1
encryption ×1
ext4 ×1
files ×1
group ×1
hashsum ×1
lvm ×1
mysql ×1
ownership ×1
permissions ×1
root ×1
rsync ×1