dmesg + 假设驱动器缓存:直写

yae*_*ael 3 rhel kernel dmesg

当我们在 rhel 7.2 上运行以下 dmesg 时,我们得到关于 assuming drive cache

dmesg --level=err
[    5.325381] sd 0:0:0:0: [sda] Assuming drive cache: write through
[    5.325492] sd 0:0:5:0: [sde] Assuming drive cache: write through
[    5.325637] sd 0:0:3:0: [sdc] Assuming drive cache: write through
[    5.325667] sd 0:0:4:0: [sdd] Assuming drive cache: write through
[    5.326309] sd 0:0:2:0: [sdb] Assuming drive cache: write through
[   10.277944] piix4_smbus 0000:00:07.3: SMBus Host Controller not enabled!
Run Code Online (Sandbox Code Playgroud)

知道这个内核错误是什么意思吗?

我已阅读 Redhat 帖子 - https://access.redhat.com/solutions/42752

但不清楚解决方案是什么?

注意 - 我必须说服务器在意外重启之后

Ste*_*itt 7

从您提供的链接中可以看出,“因此这些事件通常可以被忽略。” 这就是解决方案。

为了谨慎起见,内核会打印错误消息;这意味着内核尝试使用 SCSI 规范的可选功能来确定驱动器缓存的特征,但驱动器不支持它,因此无法获得特征。没有什么可做的。

(我所知道的唯一提供所需信息的驱动器是 SCSI 或 SAS 驱动器。)