读取 IBM 3592 JB 磁带的问题

Mag*_*ick 5 linux tape

我在使用 TS1140 (E07) 驱动器读取 3592 JB IBM (700GB) 磁带时遇到问题。磁带是使用 TS1130 (E06) 驱动器写入的,压缩率高达 1TB,如磁带标签上所指定。根据 IBM 的磁带规格网页,TS1140 驱动器应该向后兼容以读取用 TS1120 (E05) 和 TS1130 驱动器写入的磁带。但是,当我尝试读取此磁带时,它会引发 I/O 错误并在大约 240 mb 处停止。我已经设法从使用dd256K 块大小的磁带中获得高达 8GB 的​​空间,但是这也停滞不前。

例如。

[user1@server-le1 ~]$ dd if=/dev/IBMtape10 of=/myoutputpath/File_1.dat bs=512k
dd: reading `/dev/IBMtape10': Input/output error
0+46011 records in
0+46011 records out
379301796 bytes (379 MB) copied, 833.756 s, 455 kB/s
Run Code Online (Sandbox Code Playgroud)

有没有对 IBM 磁带机有经验的人能帮我解决这个问题?

磁带创建者表示他们可以使用他们的 1140 驱动器读取此内容。所以我在想这是一个需要改变的驱动器设置吗?或者还有别的什么吗?

dr_*_*dr_ 3

在这里提出一些想法。这可能会解决您的问题,也可能根本无法解决您的问题,但我会尝试使用以下方法复制内容cat:

cat /dev/IBMtape10 > /myoutputpath/File_1.dat
Run Code Online (Sandbox Code Playgroud)

这是因为cat将根据可用 I/O 速度自动将块大小调整为最佳值,而不强制指定缓冲区大小。

/dev/IBMtape10您也可以尝试直接通过命令进行操作mt。