您好我是新的AWS并尝试在Elastic Beanstalk中部署Spring启动应用程序.部署成功但无法访问应用程序.获取502 Bad Request Gateway nginx/1.10.1错误.部署在运行Java 8(nginx代理服务器)的Configuration 64bit Amazon Linux 2016.09 v2.2.0上完成.是否有任何方法可以解决这个问题.谷歌搜索后发现这是因为端口不匹配.我想知道我应该在哪里更改端口号.
nginx amazon-ec2 amazon-web-services spring-boot amazon-elastic-beanstalk
在构建之后无法在目标文件夹中创建.class文件.我在构建应用程序时,清理安装cmd而不是创建.class文件,任何人都可以告诉我目录是否需要更改或者?
我在spring中使用simpleJdbcInsert将一些数据插入到数据库中,它在第一步(我的意思是第一次插入)时工作正常,当我尝试第二次保存数据时,我得到例外:org.springframework.dao.InvalidDataAccessApiUsageException:配置可以一旦编译或使用了课程,就不得改变."
任何人都可以帮助我解决这个问题.