小编Sam*_*m-T的帖子

Zookeeper 管理服务器端口

在 Windows 上安装了 zookeeper 3.5.6 bin。获取错误:无法启动 AdminServer,异常退出 org.apache.zookeeper.server.admin.AdminServer$AdminServerException:在地址 0.0.0.0、端口 8080和命令 URL /commands上启动 AdminServer 时出现问题

我在哪里可以找到 AdminServer 配置属性来解决这个问题。在我的 conf 目录中,.cfg 没有任何东西,而且我在其他任何地方也找不到任何东西??该文档指的是 zookeeper.admin.serverPort 属性等。

windows-10 apache-zookeeper

12
推荐指数
1
解决办法
9216
查看次数

Ansible - 安装 python3-apt 包

使用Ubuntu 18.04, Ansible 2.9, Python 3.6.9, 已安装python3-apt

在基本的 ansible 命令上ansible -b all -m apt -a "name=apache2 state=latest" 获取错误:

FAILED! => {
    "ansible_facts": {
        "discovered_interpreter_python": "/usr/bin/python"
    },
    "changed": false,
    "msg": "Could not import python modules: apt, apt_pkg. Please install python3-apt package."
}
Run Code Online (Sandbox Code Playgroud)

$ sudo apt-get install python3-apt

$ ansible --version
ansible 2.9.12  
python version = 3.6.9

$ python --version
Python 3.7.6
Run Code Online (Sandbox Code Playgroud)

python-3.x ansible ubuntu-18.04

9
推荐指数
2
解决办法
2万
查看次数

无法连接虚拟设备sata0:1,因为主机上没有相应的设备可用

无法连接虚拟设备sata0:1,因为主机上没有相应的设备可用.

当我启用主机/来宾共享并映射驱动器时,会弹出错误.我已经安装了VMware Tools等.

我试图删除然后将sata驱动器添加回 VM Player,但它没有帮助.

我在Win10 Pro Host和Ubuntu 16.04 Desktop上使用VM Player 12.5.5.

vmware-player windows-10 ubuntu-16.04

8
推荐指数
2
解决办法
3万
查看次数

适用于Auto Scaling组的AWS多个ELB

根据AWS文档,您可以将多个Load Balancers附加到单个Auto Scaling组.我认为ELB和ASG之间会有1:1的关系.如果ASG缩放哪个ELB,它会更新 - 全部.这是如何工作的,用例是什么.

amazon-web-services amazon-elb autoscaling

6
推荐指数
2
解决办法
2992
查看次数

从 GitHub 下载目录

尝试从 git 下载文件夹。
我尝试过wget --no-parent -r http://WEBSITE.com/DIRECTORY,但也没有--no-parent- 不起作用。curl对于单个文件工作正常,我认为wget应该获取该文件夹 - 它可以执行除此之外的所有操作。

按照建议尝试了许多选项使用 wget 递归地获取其中包含任意文件的目录,但 没有成功

wget github download

6
推荐指数
1
解决办法
1万
查看次数

AWS Spot/OnDemand 实例管理

有没有办法优雅地编写脚本/配置 Spot 实例请求,如果 Spot 在某些指定的时间内不可用,只需使用 OnDemand。如果 Spot 实例被终止,只需转移到 OnDemand。

Spot Fleet 不这样做(它只管理 Spot),EMR 车队对此有一些逻辑。您可以使用 Spot 或按需自动缩放,但不能同时使用两者(即使您可以使用 2 个单独的 ASG 模拟此行为)。

这应该是某种基线用例。

当 Spot 实例启动或终止时,事件也会被触发。我只看到 CLI 来检查 Spot 状态,而不是任何 CloudWatch 指标/事件。

ondemand instances amazon-web-services

5
推荐指数
1
解决办法
200
查看次数

AWS API 网关访问私有子网

我的 VPC 中有公共和 Pvt 子网。我有一些服务在 Pvt 子网中的 EC2 上运行,需要通过外部/移动资源访问。我该怎么做 - VPCLink 和 NLB 是这样做的方式,还是其他方式,在公共子网 (??) 中创建一些访问点。Lambda 似乎是答案(现在几乎适用于 AWS 中的所有内容)——甚至不确定该访问如何对 Pvt 子网中的资源起作用。

同样的 Pvt 子网也可以访问外部资源(AWS 之外) - 如何使用 API 网关执行此操作?

不太了解 API 网关(和 Lambda)是如何相对于 VPC 和子网定位的,以及网络访问控制功能如何——它们是否可以直接访问 Pvt 子网。文档对此有些沉默,只谈论 IAM -如果有人可以解释这一点。在 Lambda 上找到了这个:AWS Lambda:如何为具有 VPC 访问权限的 lambda 函数设置 NAT 网关。

该文档说“API 网关允许您安全地连接……托管在 AWS 内部或外部的可公开寻址的Web 服务”。我在 Pvt 子网中的资源不可公开寻址 - 我想。

谢谢

amazon-web-services aws-vpc api-gateway

5
推荐指数
1
解决办法
8250
查看次数

AWS EKS kubectl - 在默认命名空间中找不到资源

尝试设置 EKS 集群。调用时发生错误 (AccessDeniedException) DescribeCluster operation:帐户 xxx 未被授权使用此服务。这个错误来自 CLI,在控制台上我能够成功地创建集群和一切。我登录为root user(它只是我的个人帐户)。

它说帐户听起来不是用户/权限问题?我是否必须为该服务启用我的帐户?我没有看到任何这样的选择。

此外,如果以用户(而不是 root)身份登录 - 我是否能够看到之前以 root 身份创建的所有内容。我现在已经创建了一个用户并分配了 admin 和 eks* 权限。我 在以用户身份登录时检查了这一点- 我可以看到所有内容。

aws cli 是使用 root 凭据设置的(我认为) - 所以我必须返回并撤消修复所有这些并只使用该用户。

更新 1
我重做/重新启动包括用户和 awscli 配置在内的所有内容 - 只是为了确保。但问题仍然没有得到解决。

有一个手动创建文件的选项- 终于奏效了。

我能够: kubectl get svc

名称 类型 CLUSTER-IP EXTERNAL-IP PORT(S) AGE kubernetes ClusterIP 10.100.0.1 443/TCP 48m

KUBECONFIG: 我已经设置了 env:KUBECONFIG

$env:KUBECONFIG="C:\Users\sbaha\.kube\config-EKS-nginixClstr"
$Env:KUBECONFIG
C:\Users\sbaha\.kube\config-EKS-nginixClstr
kubectl config get-contexts
CURRENT   NAME   CLUSTER …
Run Code Online (Sandbox Code Playgroud)

amazon-web-services amazon-iam kubernetes kubectl amazon-eks

5
推荐指数
1
解决办法
4077
查看次数

AWS OpsWorks 与 CloudFormation

我想了解OpsWorks 的确切局限性- 我们可能根本无法做到或无法以最佳方式完成的事情。这需要进入下一个级别——CloudFormation。当然,我们可以使用 OpsWorks + CloudFormation - 两全其美 - 最佳实践。

我知道 OpsWorks 的一些局限性是 - 它无法提供所有内容 - 例如 EMR、S3 等 - 但从未在详尽的列表中找到。OpsWorks AutoScaling 配置也有限制。与 OpsWorks 不同,CloudFormation 使我们能够对环境进行版本控制。请务必了解,存在大量重叠,并且 CloudFormation 确实增加了复杂性。

之前有过讨论,但界限没有明确。

amazon-web-services aws-cloudformation aws-opsworks

4
推荐指数
1
解决办法
2389
查看次数

Cassandra NoClassDefFoundError:com/google/common/util/concurrent/AsyncFunction

cluster = Cluster.builder()                                                    
                .addContactPoint("localhost")
                .build();

Exception in thread "main" java.lang.NoClassDefFoundError: com/google/common/util/concurrent/AsyncFunction
Run Code Online (Sandbox Code Playgroud)

我在我的路径中唯一的罐子是2 cassandra java驱动程序jars cassandra-driver-core-2.1.10.3.jar和cassandra-driver-mapping-2.1.10.3.jar

谢谢

cassandra datastax-java-driver

3
推荐指数
1
解决办法
2135
查看次数

用于Cassandra的Spark2会话,sql查询

在Spark-2.0中,创建Spark会话的最佳方法是什么.因为在Spark-2.0和Cassandra中,API都经过了重新设计,基本上不赞成使用SqlContext(以及CassandraSqlContext).因此,为了执行SQL,我要么创建一个Cassandra会话(com.datastax.driver.core.Session) and use execute( " ").或者我必须创建一个SparkSession (org.apache.spark.sql.SparkSession) and execute sql(String sqlText)方法.

我不知道两者的SQL限制 - 有人可以解释一下.

此外,如果我必须创建SparkSession - 我该怎么做 - 找不到任何合适的例子.随着API的重新设计,旧示例不起作用.我正在通过这个代码示例 - DataFrames - 不清楚这里使用的是什么sql上下文(是正确的方法继续.)(由于某些原因,弃用的API甚至没有编译 - 需要检查我的eclipse设置)

谢谢

java apache-spark apache-spark-sql spark-cassandra-connector apache-spark-2.0

2
推荐指数
1
解决办法
4434
查看次数

启动火花大师 windows7

使用win7-64、jdk8、sparks1.6.2。我有 spark running、winutils、HADOOP_HOME 等

根据文档 注意:启动脚本当前不支持 Windows。要在 Windows 上运行 Spark 集群,请手动启动 master 和 worker。但不说怎么办?

如何在 Windows 上启动 spark master?

尝试通过 git bash 运行 sh start-master.sh :failed to launch org.apache.spark.deploy.master.Master:即使它打印出Master --ip Sam-Toshiba --port 7077 --webui-port 8080 - 所以我不知道这一切意味着什么。但是当我尝试时spark-submit --class " " --master spark://Sam-Toshiba:7077 target/ .jar- 我得到错误:警告 AbstractLifeCycle: FAILED SelectChannelConnector@0.0.0.0: 4040: java.net.BindException: Address already in use: bind java.net.BindException: Address already in use

WARN Utils: Service 'SparkUI' could not bind on port 4040. Attempting port 4041. …
Run Code Online (Sandbox Code Playgroud)

java windows-7-x64 apache-spark

2
推荐指数
1
解决办法
563
查看次数