小编use*_*B13的帖子

Pod的状态始终为ContainerCreating。。活动显示“创建Pod沙箱失败”

我正在尝试在具有一个主节点和两个工作节点的K8s集群上创建部署。集群在3个AWS EC2实例上运行。我一直在使用这种环境玩Kubernetes。三天后,我已经开始看到所有豆荚状态更改为ContainerCreatingRunning。只有计划在主服务器上的Pod显示为Running。在工作程序节点上运行的Pod显示为ContainerCreating。当我运行时kubectl describe pod <podname>,它在事件中显示以下内容

 Events:
  Type     Reason                  Age   From                      Message
  ----     ------                  ----  ----                      -------
  Normal   Scheduled               34s   default-scheduler         Successfully assigned nginx-8586cf59-5h2dp to ip-172-31-20-57
  Normal   SuccessfulMountVolume   34s   kubelet, ip-172-31-20-57  MountVolume.SetUp succeeded for volume "default-token-wz7rs"
  Warning  FailedCreatePodSandBox  4s    kubelet, ip-172-31-20-57  Failed create pod sandbox.
  Normal   SandboxChanged          3s    kubelet, ip-172-31-20-57  Pod sandbox changed, it will be killed and re-created.
Run Code Online (Sandbox Code Playgroud)

这个错误现在困扰着我。我试图在网上搜索有关的错误,但是我没有得到任何具体的信息。我在包含主节点和工作节点的群集上进行了kubeadm重置,然后再次启动了群集。节点状态显示为就绪。但是,每当尝试使用以下命令创建部署时,我都会再次遇到相同的问题:

kubectl run nginx --image=nginx --replicas=2
Run Code Online (Sandbox Code Playgroud)

kubernetes

5
推荐指数
2
解决办法
6526
查看次数

标签 统计

kubernetes ×1