无法在Ubuntu 12.04上启动MySQL5.5 - "dpkg:依赖问题"

Arc*_*nic 21 ubuntu-12.04 mysql-5.5

这似乎是12.04的常见问题.我在这个帖子中尝试过,包括:

sudo apt-get clean

sudo apt-get autoclean

sudo apt-get remove --purge mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5

sudo apt-get install mysql-server
Run Code Online (Sandbox Code Playgroud)

我仍然得到同样的错误.安装/启动MySql5.5如下所示:

apt-get install -f mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
mysql-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up mysql-server-5.5 (5.5.24-0ubuntu0.12.04.1) ...
120907 21:37:15 [Note] Plugin 'FEDERATED' is disabled.
120907 21:37:15 InnoDB: The InnoDB memory heap is disabled
120907 21:37:15 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120907 21:37:15 InnoDB: Compressed tables use zlib 1.2.3.4
120907 21:37:15 InnoDB: Initializing buffer pool, size = 128.0M
120907 21:37:15 InnoDB: Completed initialization of buffer pool
120907 21:37:15 InnoDB: highest supported file format is Barracuda.
120907 21:37:15  InnoDB: Waiting for the background threads to start
120907 21:37:16 InnoDB: 1.1.8 started; log sequence number 154164236
120907 21:37:16  InnoDB: Starting shutdown...
120907 21:37:16  InnoDB: Shutdown completed; log sequence number 154164236
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.

Errors were encountered while processing:
 mysql-server-5.5
 mysql-server
Run Code Online (Sandbox Code Playgroud)

另外,dpkg-reconfigure mysql-server-5.5退货/usr/sbin/dpkg-reconfigure: mysql-server-5.5 is broken or not fully installed

这里的最终目标是安装和配置Gitorious以与Redmine一起工作,但我相信问题是与Ubuntu 12.04和MySql5.5隔离的

小智 52

我找到了这个步骤的解决方案:

警告:以下步骤将删除现有数据!请先备份!!!

$ sudo apt-get --yes autoremove --purge mysql-server-5.5

$ sudo apt-get --yes autoremove --purge mysql-client-5.5

$ sudo apt-get --yes autoremove --purge mysql-common

$ sudo rm -rf /var/lib/mysql /etc/mysql ~/.mysql



$ sudo deluser mysql

$ sudo apt-get autoclean

$ sudo apt-get update && sudo apt-get upgrade

$ sudo apt-get install mysql-server-5.5 mysql-client-5.5
Run Code Online (Sandbox Code Playgroud)

注意:当你得到'dpkg:error ...'时,请运行以下步骤:

$ sudo dpkg --configure -a
Run Code Online (Sandbox Code Playgroud)

祝好运!

  • 这是唯一能解决我损坏的mysql-server和客户端的解决方案.我错过的东西是清除mysql客户端和/ var/lib/mysql和〜/ .mysql中的文件谢谢! (3认同)

Arc*_*nic 7

来自Ubuntu论坛的修复:

这对我有用,虽然我正在进行安装而不是升级,所以我不关心现有的数据库.

我再次删除了所有的mysql应用程序,然后我去了我的/ var/lib/mysql目录.请记住,如果你有一个现有的数据库,你将失去它.您可能希望将其移动到其他位置.

删除该目录后,我再次安装,它完美无缺.所以/ var/lib/mysql目录中的东西是我的问题.看看它是否适合你.