运行报表时,用户数据源凭据不符合运行此报表或共享数据集错误的要求

Cha*_*les 16 reporting-services

尝试运行报告时出现以下错误:

目前的行动无法完成.用户数据源凭据不符合运行此报告或共享数据集的要求.用户数据源凭据未存储在报表服务器数据库中,或者用户数据源配置为不需要凭据,但未指定无人参与的执行帐户.(rsInvalidDataSourceCredentialSetting)

顺便说一下,我使用SQL Server 2008 Reporting Services从VS2010运行它.

我该如何解决这个问题?

Jer*_*oen 14

是的,我见过这个.您可以设置凭据和连接信息,以便运行模拟无人参与用户帐户的报告.本文介绍如何设置此类型的报表运行.如果要在动态连接字符串中使用凭据(例如,当您需要通过参数插入凭据时),此设置特别有用.

如果您不想使用无人参与的用户帐户运行,则应检查报告中定义的DataSource和连接字符串.也许可以使用数据源的设置和不同配置来创建不同的设置.以上链接应该是一些文档的开头.


hol*_*gon 8

就我而言,这是因为一些部署参数。

  1. 右键单击“解决方案资源管理器”中的项目名称,转到“项目属性”,然后选择“属性”。
  2. 在“配置属性”>“常规”中,将“部署”部分中的 OverwriteDatasets 和 OverwriteDataSources 这两个参数都更改为True。
  3. 单击“确定”。