无法启动mysqld_safe来重置root密码

jcp*_*den 8 mysql centos root

我安装了MySQL并且正在尝试使用密码设置来尝试让Wordpress连接到它.这样做,我似乎已经删除了我的root密码,现在无法登录.

我正在尝试通过运行来重置密码

/etc/init.d/mysqld stop
Run Code Online (Sandbox Code Playgroud)

然后

mysqld_safe --skip-grant-tables
Run Code Online (Sandbox Code Playgroud)

哪个输出

Starting mysql daemon with databases from /var/lib/mysql
Run Code Online (Sandbox Code Playgroud)

但后来什么也没做.它既不成功也不失败.我没有任何数据库设置所以我很乐意删除并重新安装mysql如果有必要,但我尝试了无济于事.我怎么能回来?

oct*_*ern 13

mysqld_safe是启动mysql引擎的命令.它不应该在行之后做或显示任何内容,说它已经启动了mysql.一旦运行mysqld_safe,下一步就是运行mysql.因为您启动了mysqld,--skip-grant-tables所以不需要指定用户名或密码.

然后,您可以命令重置root的密码.有关如何设置密码的说明,请参阅http://dev.mysql.com/doc/refman/5.0/en/set-password.html.