无法使用vs2010访问tfs服务器,返回404错误

Chr*_* Li 5 tfs visual-studio-2010

我正在使用vs2010和tfs2010来完成我的工作.我的同事可以访问服务器.当我尝试访问http:// mytfs:8080 /的服务器时,它响应:balbla和3个可能的原因并且"远程服务器返回错误:(404)Not Found."

我查看了我的客户设置并与同事比较,没有什么不同.没有tfs代理,只有默认的IE代理设置.没有设置路径.我的系统帐户管理(Windows XP)中没有存储的凭据,相同的DNS /主机设置.

此外,我可以使用命令窗口使用端口8080 telnet服务器.我也可以在我的网络浏览器中使用我的域帐户浏览http:// mytfs:8090 /.此外,管理员告诉我,由于tfs服务器的日志,它已收到我的发布请求并回复200 OK.我尝试将mytfs更改为ip地址,但仍然得到404响应.

我搜索了问题并发现它很像这样,但补丁无法安装(说这个更新不适用或被其他条件阻止).有人可以帮忙吗?非常感谢.

Chr*_* Li 15

我发现了问题.这是因为tfs使用缓存连接到旧服务器以进行NTLM身份验证,该身份验证已经关闭.

我使用fiddler监视连接到tfs服务器时会发生什么.它首先将数据发布到http:// mytfs:8080/TeamFoundation/Administration/v3.0/LocationService.asmx并获得401响应,然后转到http:// oldtfs:8080/Services/v1.0/GroupSecurityService.asmx ,响应502,然后http:// mytfs:8080/TeamFoundation/Administration/v3.0/LocationService.asmx响应404(这是一个奇怪的响应).

因此必须有一些配置来保留旧服务器的授权信息.检查主机文件并注册后.我认为它可能是缓存授权URL的tfs客户端.所以我删除了C:\ Documents and Settings\myaccount\Local Settings\Application Data\Microsoft\Team Foundation\3.0\Cache,重启vs2010,它可以成功连接.

希望这可以帮助有同样问题的人.