Crystal Report Engine运行时错误

jjj*_*jjj 3 asp.net runtime-error reference business-objects crystal-reports

你好,

我将项目视觉工作室和水晶报告转换为版本10

但服务器有旧版本,所以我必须添加旧的引用

IT显示报告,但我在打印和引擎问题上遇到问题

Crystal Report Bar Engine:

报告栏

服务器消息:

服务器错误消息

本地留言:

Server Error in '/' Application. 
-------------------------------------------------------------------------------- 

HTTP Error 404 - Not Found. 

-------------------------------------------------------------------------------- 
Version Information: ASP.NET Development Server 10.0.0.0
Run Code Online (Sandbox Code Playgroud)

试过:

- 重新安装Crystal Report 10.

- 删除所有Crystal Report引用并再次添加.

- 清理解决方案,删除引用并再次添加.

(〜最新结果(现状):

我意识到我已经安装CRforVS_13_0_2了包CRRuntime_64bit_13_0_2.msi,我的计算机是32位操作系统..所以我安装CRRuntime_32bit_13_0_2.msi它完成安装不像 CRRuntime_64bit_13_0_2.msi..但Business Objects的问题仍然在那里,因为它在"Crystal Report Bar Engine"中显示" 图片 .〜)

注意:如果我添加水晶报告的新参考,它肯定在本地工作但不在

服务器 .所以我必须使用旧的参考资料.

救命 .

Ema*_*eco 5

分析问题

可以分析问题,并找到403(禁止)错误

  • 使用客户端工具(浏览器的调试窗口)

GET http://someServer:20080/aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/crv.js 403 (Forbidden)
GET http://someServer:20080/aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/images/style.css 403 (Forbidden)

  • 或服务器工具(IIS日志,放在WIN2003上%SYSTEMROOT%\System32\LogFiles\W3SVC###\).

2011-03-28 13:00:49 W3SVC701536 95.228.38.41 GET /aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/images/style.css - 20080 - 192.168.1.2 Mozilla/5.0 +(兼容; + MSIE + 9.0 ; + Windows + NT + 6.1; + Trident/5.0)403 6 64 Errore!2011-03-28 13:00:49 W3SVC701536 95.228.38.41 GET /aspnet_client/system_web/4_0_30319/crystalreportviewers13/js/crviewer/crv.js - 20080 - 192.168.1.2 Mozilla/5.0 +(兼容; + MSIE + 9.0; + Windows + NT + 6.1; + Trident/5.0)403 6 64 Errore!

导致问题

  • 在这两种情况下,我发现crv.js并style.css没有提供一些文件;
  • 这些文件由CR安装程序放在wwwroot\aspnet_client文件夹中,但由于某些原因无法访问;
  • 在我的情况下,原因是我创建了一个不同的网站(端口20080)和aspnet_client文件夹没有放在该网站内

我可以看到你使用不同版本的软件和不同的配置,但我认为你有同样的问题.

解

解决方案是以这种方式在IIS上工作:

  • 将aspnet_client文件夹从c:\inetpub\wwwroot文件夹复制到新网站根文件夹.

或者(这个更好)

  • 创建一个名为aspnet_client指向新网站内部的虚拟目录c:\inetpub\wwwroot