在Aptana中获取Subclipse以使用最新版本的Subversion

cmcculloh 41 aptana eclipse subclipse svn

目前通过Aptana的自动插件管理器提供的Subclipse(1.2.4)版本不适用于最新版本的Subversion.

我在Subclipse网站上看到他们的Eclipse有1.4.2.所以我向我的Update Manager 添加了一个新的远程更新站点.当我尝试安装它时,它告诉我我需要Mylyn 3.0.0.经过多次搜索后,我找到了Mylyn 3.0.0,并为我的更新管理器添加了另一个新的远程更新站点.然后,当我尝试安装它时,它告诉我我需要org.eclipse.ui 3.3.0或同等的.

看一下Aptana的配置细节,看起来它是针对eclipse 3.2.2构建的.

有谁知道是否有办法升级针对3.3.0构建的Eclipse Aptana版本?或者,如果有其他方法让Subclipse与最新版本的Subversion一起使用?

我知道这不一定是一个"编程"问题,但我希望它没关系,因为它与编程经验高度相关.

Mark Phippar.. 16

Subclipse不需要Mylyn,但更新站点包含一个集成了Mylyn和Subclipse的插件.这适用于使用Mylyn的用户.在您的情况下,您可能希望在更新对话框中取消选择Mylyn.

Subclipse还需要Subversion 1.5和相应版本的JavaHL本机库.我已经编写了常见问题解答的开头,以帮助人们了解JavaHL以及如何获取它.请参阅:http://desktop-eclipse.open.collab.net/wiki/JavaHL


用户甲.. 7

我在Eclipse Ganymede中遇到了JavaHL的问题,当它在Eclipse Europa中运行良好时.我不确定Aptana是如何不同的,但尝试升级JavaHL或切换到Subclipse配置中的纯java SVNKit实现.