ActiveMQ 控制台不可用

DP_*_*DP_ 5 activemq-classic

我在 Windows 计算机上安装了 ActiveMQ 5.5.0,它有一个开箱即用的 Web 控制台 (http://localhost:8161/admin)。

然后我在远程Linux机器(IP:AAA.BBB.CCC.DDD)上安装了ActiveMQ(相同版本),但是每当我将浏览器指向

http://AAA.BBB.CCC.DDD:8161/admin

我在浏览器中收到“无法连接”错误。

网络连接就在那里,我可以通过 ssh 连接到 AAA.BBB.CCC.DDD 以及在同一服务器上运行的另一个 Web 应用程序。

因此我认为问题的原因是ActiveMQ的嵌入式Jetty服务器配置错误。

如何解决该问题,即启用从远程浏览器访问 Web 控制台?

wal*_*ker 8

  1. 进入/opt/activemq/apache-activemq-5.16.3/conf
  2. 打开jetty.xml
  3. 改变
 <property name="host" value="127.0.0.1"/>
Run Code Online (Sandbox Code Playgroud)

到

<property name="host" value="0.0.0.0"/>
Run Code Online (Sandbox Code Playgroud)
  1. 重启activemq


Jak*_*rab 4

在您的 ActiveMQ 配置文件中,您应该看到类似以下内容:

<import resource="${activemq.base}/conf/jetty.xml"/>
Run Code Online (Sandbox Code Playgroud)

这将使用 Web 控制台启动嵌入式 Jetty 容器。

如果您在控制台上启动代理,如果一切正常,您应该看到以下内容

 INFO | ActiveMQ WebConsole initialized.
 INFO | Initializing Spring FrameworkServlet 'dispatcher'
 INFO | ActiveMQ Console at http://0.0.0.0:8161/admin
Run Code Online (Sandbox Code Playgroud)

  • 原因完全不同 - 当我通过办公室 WLAN 连接时,该地址不起作用。当我通过手机连接时,它可以工作。我认为原因是防火墙设置。 (4认同)