MongoDB 失败(结果:核心转储)?

Cas*_*vel 15 ubuntu mongodb

我正在尝试按照文档在 Ubuntu 20.04.02 LTS 上设置 MongoDB 。我已确保这是全新安装。但是,当我通过输入以下内容验证 MongoDB 安装是否成功启动时,错误仍然存​​在:

\n
\n

sudo systemctl 状态 mongod

\n
\n
\n

\xe2\x97\x8f mongod.service - MongoDB 数据库服务器\n已加载:已加载(/lib/systemd/system/mongod.service;已禁用;供应商预置>\n活动:自 2021 年 8 月星期三以来失败(结果:核心转储) -11 12:59:20 UTC; 49s >\n文档:https://docs.mongodb.org/manual \n进程:3190 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dum > 主PID:3190(代码=转储,信号=ILL)

\n

8 月 11 日 12:59:19discorddomagoj systemd 1:已启动 MongoDB 数据库\n服务器。8 月 11 日 12:59:20 discorddomagoj systemd 1 : mongod.service:\n主进程退出,> 8 月 11 日 12:59:20 Discorddomagoj systemd 1 :\nmongod.service: 失败,结果\'>

\n
\n

为了清楚起见,问题图片:\n问题图片

\n

Abd*_*hab 28

mongod1.通过发出以下命令停止进程:-

    sudo service mongod stop
    
Run Code Online (Sandbox Code Playgroud)

2.删除您之前安装的所有 MongoDB 软件包:-

    sudo apt-get purge mongodb-org*
    
Run Code Online (Sandbox Code Playgroud)

3.删除 MongoDB 数据库和日志文件:-

    sudo rm -r /var/log/mongodb
    sudo rm -r /var/lib/mongodb
    
Run Code Online (Sandbox Code Playgroud)

4.然后重新安装mangodb 4.4.8

5.导入包管理系统使用的公钥:-

    wget -qO - https://www.mongodb.org/static/pgp/server-4.4.asc | sudo apt-key add -
    
Run Code Online (Sandbox Code Playgroud)

6.以下说明适用于 Ubuntu 20.04 (Focal):-

    echo "deb [ arch=amd64,arm64 ] https://repo.mongodb.org/apt/ubuntu focal/mongodb-org/4.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-4.4.list
    
Run Code Online (Sandbox Code Playgroud)

7.更新APT

    sudo apt-get update
    
Run Code Online (Sandbox Code Playgroud)

8.安装mongodb

    sudo apt-get install mongodb-org=4.4.8 mongodb-org-server=4.4.8 mongodb-org-shell=4.4.8 mongodb-org-mongos=4.4.8 mongodb-org-tools=4.4.8
    
Run Code Online (Sandbox Code Playgroud)

9.mongod --version使用查看是否安装成功

10.如果您在使用过程中遇到任何错误mongod

    sudo mkdir /data
    cd /data
    sudo mkdir db
    sudo pkill -f mongod
    
Run Code Online (Sandbox Code Playgroud)

11.然后使用sudomongod命令。

  • `mongod --version`给出了`非法指令(核心转储)` (3认同)

Pho*_*nix 10

此错误表明 CPU 与 mongodb 不兼容。如果使用 proxmox 将 cpu 模式设置为“HOST”。

  • 这对我来说是正确的答案。Proxmox 默认 VM CPU 类型 kvm64 的问题是它不支持 mongodb v5+ 所需的 AVX 指令。更多信息:https://forum.proxmox.com/threads/mongo-db-5-0-not-install.95857/#post-440005 (6认同)

Rob*_*ler 5

转储的一个可能原因是5.0 版本引入的 MongoDB微架构要求发生了变化。例如,这会在 Raspberry Pi 上导致这个问题(请参阅:MongoDB 论坛)。

如论坛帖子中所述,可以通过从源代码构建来缓解此问题。我个人还没有尝试过这个。安装 5.0 之前的版本(如 Abdul Wahhab 所描述)也可以解决该问题。

2023 年 10 月更新:您可以从此Github 存储库获取非官方二进制文件。MongoDB 团队的一名成员正在提供它们。