HTTP 错误 500.30 - 新创建的应用服务的 ANCM 进程内启动失败

Mir*_*roo 1 azure azure-web-app-service

我们创建了新的开发环境,因此我将当前工作的应用程序服务克隆到新的环境中,并更改了配置并部署了相同的代码,但HTTP Error 500.30 - ANCM In-Process Start Failure 在尝试控制台获取更多详细信息后,新的应用程序服务正在返回,这就是我得到的,我不认为它与运行时标识符有关,因为相同的代码在不同的确切应用程序服务上运行在此输入图像描述

小智 7

可怕的 500.3x ACNM 错误可能意味着不同的事情,所以我将帮助您查明这些事情。

我的建议:转到Azure门户>您的应用服务>开发工具

打开控制台。

屏幕应如下所示: 控制台屏幕 Azure

输入 (YourWebAppName).exe

这将显示与您的启动问题相关的错误消息。

另外,可以在此处查看有关错误的一些信息: https: //learn.microsoft.com/en-us/aspnet/core/test/troubleshoot-azure-iis ?view=aspnetcore-3.1#app-startup-errors