Nginx 目录遍历问题

Nij*_*jo 5 tomcat nginx nginx-reverse-proxy

我正在运行 Nginx 1.16.1 版本来为我的 Django 应用程序提供服务,并且还用作反向代理来为我的来自 tomcat 的 spring boot api 提供服务。以下是我的nginx配置:

server {

       listen 80 default_server;

       server_name domain_name;

       error_log /home/ubuntu/logs/nginx_error.log;
       access_log /home/ubuntu/logs/nginx_acess.log;

       location / {

           uwsgi_pass unix:///home/ubuntu/django-app/uwsgi.sock;
           include uwsgi_params;
        }

       location /api/ {

               proxy_pass http://localhost:9092/;
               proxy_set_header X-Real-IP $remote_addr;
               proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
               proxy_set_header Host $http_host;
       }
}
Run Code Online (Sandbox Code Playgroud)

当我到达 URL 时:http://domain_name/api/v1/../../ 它登陆 django 主页。这是因为路径遍历漏洞。如果是这样,有没有办法克服这个问题?