Alo*_*ali 3 google-chrome http-status-code-504 angular angular-service-worker angular-pwa
我正在开发一个有角度的 PWA 应用程序。所以我添加了一个 npm 包ng add @angular/pwa。它添加成功,没有错误。
生成的清单工作正常。但我正面临服务工作者的问题。当应用程序上线时,它会存储所有缓存(请参阅附件),但每当应用程序下线时,它会显示错误 - HTTP ERROR 504,而不是服务于来自 Service Worker 的请求
这是我的ngsw-config.json -
{
"index": "/index.html",
"assetGroups": [
{
"name": "app",
"installMode": "prefetch",
"resources": {
"files": ["assets/images/favicon.ico", "/index.html", "/*.css", "/*.js"]
}
},
{
"name": "assets",
"installMode": "lazy",
"updateMode": "prefetch",
"resources": {
"files": [
"/assets/**",
"/*.(eot|svg|cur|jpg|png|webp|gif|otf|ttf|woff|woff2|ani)"
]
}
}
]
}
Run Code Online (Sandbox Code Playgroud)
任何帮助将是可观的......
504 错误不是来自您的服务器,而是来自充当代理的 Service Worker。
您在 PWA 中发出的每个 HTTP 请求都会通过 Service Worker (SW),并且可能会发生两种情况:
因此,如果您处于离线状态并且资源不在 SW 缓存中,那么 SW 将尝试向服务器发出请求,但是,由于您处于离线状态,该请求将失败并且 SW 将返回 504 错误。您可以在您发布的最后一张图片中看到这实际上发生了:顶部的 http 响应是您从软件获得的错误 504 的响应,下面的请求(请参阅左侧的滚轮图标)是软件执行的请求到服务器并失败。
现在,您可能想知道,为什么软件在其缓存中找不到资源?
好吧,Angular Service Worker 是一个很棒的工具,但它非常敏感,以至于最小的更改都会使其无法正常工作。您需要了解的第一件事是它使用的缓存机制。基本上,当你构建你的 Angular 应用程序时,所有生成的文件都有一个关联的哈希,它是用每个文件的内容计算的(检查生成的ngsw.json文件)。当您的应用程序运行时,软件会将这个哈希值(在编译时计算)与请求资源的哈希值(在运行时计算)进行比较。
许多用户报告此机制存在问题,一些常见原因是:
所有这些都会对文件内容产生更改,因此软件将计算与编译时计算的哈希不同的哈希。这将导致缓存不匹配,并且您的应用程序将无法脱机工作(您将收到 http 504 响应)。
请注意,一些用户报告说该应用程序有时或在某些特定浏览器中脱机工作。一种可能的解释是浏览器级缓存机制在这些情况下起作用,而不是软件缓存本身。
要进一步调试 Angular SW,您可以在 上查看其自托管调试页面/ngsw/state。
我建议您阅读Angular Service Worker的文档和这个讨论。
正如我们所评论的,您的问题与您的 Web 服务器或代理 nginx 有关。由于您已正确连接 nginx,因此您的浏览器未启用 PWA 离线功能。在了解您的问题之后,我发现您可以在 nginx 中使用几种配置,以允许 PWA 在离线情况下正确运行。
在google 开发人员中,您可以在 nginx 配置文件中添加这些行,以允许 PWA 行为:
location ~* (service-worker\.js)$ {
# tells browsers the service worker scope
add_header 'Service-Worker-Allowed' '/app';
}
Run Code Online (Sandbox Code Playgroud)
我还在Philip Heltweg 博客中找到了这个配置文件,它允许 PWA 的完整行为。
server {
listen 80;
server_name _;
gzip on;
gzip_types text/html text/css application/javascript;
root /var/www/;
index index.html;
# Force all paths to load either itself (js files) or go through index.html.
location /index.html {
try_files $uri /index.html;
add_header Cache-Control "no-store, no-cache, must-revalidate";
}
location / {
try_files $uri /index.html;
expires 1y;
add_header Cache-Control "public";
}
}
Run Code Online (Sandbox Code Playgroud)
好吧,最后,我发现了一个有趣的 docker,如果你愿意使用 docker(当然),以简单的方式运行具有正确配置的 nginx Web 服务器。看一下这个。
我希望这三种不同的方法可以解决您的问题。如果我能提供更多帮助,请告诉我!
| 归档时间: |
|
| 查看次数: |
2438 次 |
| 最近记录: |