22 iis-express
尝试调试配置为在Visual Studio 2010中使用IIS Express 7.5的Web应用程序时,我收到以下错误"无法启动IIS Express Web服务器"
当使用/ trace:error开关从命令行运行时,我得到以下内容
C:\ Program Files(x86)\ IIS Express> iisexpress.exe/trace:error
启动IIS Express ...
初始化W3服务器启动CTC = 1857831
W3服务器初始化WinSock.CTC = 1857847
W3服务器WinSock已初始化.CTC = 1857847
W3 Server ThreadPool已初始化(ipm已发出信号).CTC = 1857847
无法调用RegisterModule for dll = C:\ Program Files(x86)\ IIS Express\loghttp.dll,mod = HttpLoggingModule
使用hr = 800706ba处理失败
加载全局模块时出错.hr = 800706ba
终止W3_SERVER对象
启动listenerChannel http:0
初始化W3服务器已启动CTC = 1858845
W3服务器初始化WinSock.CTC = 1858861
W3服务器WinSock已初始化.CTC = 1858861
W3 Server ThreadPool已初始化(ipm已发出信号).CTC = 1858861
无法调用RegisterModule for dll = C:\ Program Files(x86)\ IIS Express\loghttp.dll,mod = HttpLoggingModule
使用hr = 800706ba处理失败
加载全局模块时出错.hr = 800706ba
终止W3_SERVER对象
InitComplete事件已发出信号
报告ListenerChannel因失败而停止; ProtocolId:http,ListenerChannelId:0
进程模型关闭,称为
等待所有LISTENER_CHANNELS停止
无法启动'HostedWASStart'.错误= 34022648
HostableWebCore激活失败.
无法启动iisexpress.
笔记 -
我尝试过多次卸载和重新安装IIS Express 7.5并获得相同的结果.
我正在运行Windows 7 64位计算机
IIS Express几个月来一直没有问题.该问题仅在今天早上重新启动计算机后才开始.
小智 16
我昨晚做了一次Windows更新后得到了同样的东西.所以我修复我的做法重命名为自动创建的文件夹"IISExpress",它在我的系统中位于My Documents文件夹中.然后我重新启动VS,它为我重新创建了IISExpress文件夹 - 恢复工作状态.然后再次启动VS,问题应该解决.至少它在我的系统上工作.
Gar*_*ett 14
一些可能有用的建议:
你是如何重新安装iis-express的?如果尚未执行此操作,则可以尝试重新安装包含iis-express的Visual Studio 2010 SP1.
尝试使用进程监视器来监视iis-express进程,以查看在尝试启动它时是否存在任何权限问题.
作为最后的手段,您可以通过修改applicationhost.config位于%userprofile%\documents\IISexpress\config目录中的,来禁用日志记录模块.为此,您需要在文件中注释掉几行.
在<system.webServer>/<globalModules>元素下,注释掉该行
<add name="HttpLoggingModule" image="%IIS_BIN%\loghttp.dll" />
Run Code Online (Sandbox Code Playgroud)
在<location>/<system.webServer>/<modules>元素下,注释掉该行
<add name="HttpLoggingModule" lockItem="true" />
Run Code Online (Sandbox Code Playgroud)
保存更改后,请尝试重新启动iis express.
| 归档时间: |
|
| 查看次数: |
56535 次 |
| 最近记录: |