当模式注册表的主更改时连接器失败

Hun*_*orn 5 apache-kafka apache-kafka-connect confluent-schema-registry

我的源连接器抛出 Caused by: io.confluent.kafka.schemaregistry.client.rest.exceptions.RestClientException: Error while forwarding register schema request to the master; error code: 50003

或者 Caused by: io.confluent.kafka.schemaregistry.client.rest.exceptions.RestClientException: Master not known

我发现当模式注册表的主更改并且我在 k8s 上的同一服务下有两个模式注册表副本时会发生这种情况。

最上面的异常是org.apache.kafka.connect.errors.ConnectException: Tolerance exceeded in error handler

如何增加容忍度,以便连接器可以重试更多次,直到选出新的主节点?

cri*_*007 0

仅仅因为您有两个副本并不意味着它们彼此了解。

了解如何解决此问题 - https://github.com/confluenceinc/cp-helm-charts/issues/375


关于错误处理程序,您可以设置超时。文档中的示例。

# retry for at most 10 minutes times waiting up to 30 seconds between consecutive failures
errors.retry.timeout=600000
errors.retry.delay.max.ms=30000
Run Code Online (Sandbox Code Playgroud)