Vel*_*dan 11 django ip tcp docker docker-compose
他大家。我正在使用 docker 并尝试 dockerize 一个简单的 django 应用程序,该应用程序将外部 http 连接到网页(真实网站),因此当我在 Docker 文件中设置应该在容器中工作的 django 服务器的地址时 - 127.0 .0.1:8000。我的应用程序无法运行,因为无法与网站建立外部连接。
但是当我为我的服务器设置端口时:0.0.0.0 : 8000它开始工作。
所以我的问题是:为什么它会这样?在这种特殊情况下有什么区别?我只是想了解它。
我读了一些关于 0.0.0.0 的文章,它就像一个允许使用 OC 默认端口的“通用”或“占位符”端口。
127.0.0.1 就像一个主机,将请求重定向到当前机器。我就知道。但是当我在我的本地机器(主机:127.0.0.0:8000)上运行应用程序时,一切正常,应用程序可以连接到真实网站,但在 docker 的情况下它停止工作。
谢谢你的帮助!
这是我的来源:Docker 文件
FROM python:3.6
RUN mkdir /code
WORKDIR /code
COPY requirements.txt ./
RUN pip install --no-cache-dir -r requirements.txt
COPY . ./
EXPOSE 8000
ENTRYPOINT [ "python", "manage.py" ]
CMD [ "runserver", "127.0.0.1:8000" ] # doesn't work
# CMD [ "runserver", "0.0.0.0:8000" ] - works
Run Code Online (Sandbox Code Playgroud)
docker-compose.yml
version: "3"
services:
url_rest:
container_name: url_keys_rest
build:
context: .
dockerfile: Dockerfile
image: url_keys_rest_image
stdin_open: true
tty: true
volumes:
- .:/var/www/url_keys
ports:
- "8000:8000"
Run Code Online (Sandbox Code Playgroud)
这是我在 127.0.0.1 的情况下收到的 http 错误。也许它会很有用。
http: error: ConnectionError: HTTPConnectionPool(host='127.0.0.1', port=8000): Max retries exceeded with url: /api/urls (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x10cd51e80>: Failed to establish a new connection: [Errno 61] Connection refused')) while doing GET request to URL: http://127.0.0.1:8000/api/urls
Run Code Online (Sandbox Code Playgroud)
Dav*_*aze 22
您必须将容器的主进程设置为绑定到特殊的 0.0.0.0 “所有接口”地址,否则它将无法从容器外部访问。
在 Docker 127.0.0.1 中几乎总是意味着“这个容器”,而不是“这台机器”。如果您从容器建立到 127.0.0.1 的出站连接,它将返回到同一个容器;如果您将服务器绑定到 127.0.0.1,它将不接受来自外部的连接。
Docker 所做的核心事情之一是为每个容器提供自己独立的网络空间。特别是,每个容器都有自己的lo接口和自己的localhost.
在非常低的级别,网络服务调用bind (2) 系统调用来开始接受连接。这需要一个地址参数。它可以是以下两种情况之一:要么是某个系统接口的 IP 地址,要么是特殊的 0.0.0.0 “所有接口”地址。如果您选择一个接口,它将只接受来自该接口的连接;例如,如果物理系统上有两个网卡,则可以使用它来仅接受来自一个网络的连接,而不接受来自另一个网络的连接。
因此,如果您将服务设置为绑定到 127.0.0.1,那就是lo接口的地址,并且该服务将只接受来自该接口的连接。但是每个容器都有自己的lo接口和自己的localhost,所以这个设置会导致服务拒绝连接,除非它们是从容器本身内部启动的。如果您将其设置为绑定到 0.0.0.0,它还将接受来自每个容器eth0接口的连接,来自容器外部的所有连接都到达该接口。
我的理解是docker是随机分配IP地址给每个容器而不是localhost(127.*.*.*)。因此,使用 0.0.0.0 在 docker 应用程序内部监听是可行的。我之前尝试使用 localhost 连接 docker 文件内的本地数据库。它也不起作用。我想也是因为这个原因吧。如果我错了请纠正我!
更新:我附上一个直观的图像来显示 docker 如何与这些 IP 地址交互。希望这有助于理解。
| 归档时间: |
|
| 查看次数: |
9510 次 |
| 最近记录: |