Nie*_*cas 6 homebrew elasticsearch
我通过自制软件使用 Elasticsearch 6.8,并尝试升级到 7.3。以前,在 6.8 上,我已经收到有关不存在的日志文件的警告,但服务器仍会运行 - 所以我什么也没做。
现在使用 7.3,出现错误并且服务器无法运行:
Exception in thread "main" java.lang.RuntimeException: starting java failed with [1]
output:
[0.002s][error][logging] Error opening log file 'logs/gc.log': No such file or directory
[0.002s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed.
error:
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Invalid -Xlog option '-Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m', see error log for details.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
at org.elasticsearch.tools.launchers.JvmErgonomics.flagsFinal(JvmErgonomics.java:111)
at org.elasticsearch.tools.launchers.JvmErgonomics.finalJvmOptions(JvmErgonomics.java:79)
at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:57)
at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:89)
Run Code Online (Sandbox Code Playgroud)
我尝试创建安装了 elasticsearch 的目录/文件,但这对我不起作用(或者我做错了什么)。
Xit*_*ing 16
参考:https : //onecompiler.com/questions/3uwszcf3x/homebrew-installed-elasticsearch-failing-to-start
我通过将相对日志/gc.log 路径更改为绝对路径来解决此问题。请按照以下步骤解决问题
打开位于 /usr/local/etc/elasticsearch/jvm.options 的 jvm.options 文件
将相对路径从以下更改为绝对路径
# JDK 9+ GC logging
9-:-Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m
Run Code Online (Sandbox Code Playgroud)
到
# JDK 9+ GC logging
9-:-Xlog:gc*,gc+age=trace,safepoint:file=/usr/local/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m
Run Code Online (Sandbox Code Playgroud)
$ brew services restart elasticsearch-full或直接在没有守护进程的情况下启动它 -$ elasticsearch| 归档时间: |
|
| 查看次数: |
2649 次 |
| 最近记录: |