无法启动 Confluence 架构注册表

sai*_*hna 5 apache-kafka confluent-schema-registry confluent-platform

我已经在 Ubuntu 16.04 机器上安装了合流平台,最初我已经配置了 Zookeeper、Kafka 和 ksql 并启动了合流平台。我能够看到下面的消息。

 root@DESKTOP-DIB3097:/opt/kafkafull/confluent-5.1.0/bin# ./confluent start
 This CLI is intended for development only, not for production
 https://docs.confluent.io/current/cli/index.html
 Using CONFLUENT_CURRENT: /tmp/confluent.HUlCltYT
 Starting zookeeper
 zookeeper is [UP]
 Starting kafka
 kafka is [UP]
 Starting schema-registry
 schema-registry is [UP]
 Starting kafka-rest
 kafka-rest is [UP]
 Starting connect
 connect is [UP]
 Starting ksql-server
 ksql-server is [UP]
 Starting control-center
 control-center is [UP]
Run Code Online (Sandbox Code Playgroud)

现在一切都准备好了,当我检查汇合平台的状态时,我发现架构注册表、连接和控制中心都已关闭。

我检查了模式注册表的日志并发现了以下日志。


ERROR Error starting the schema registry (io.confluent.kafka.schemaregistry.rest.SchemaRegistryRestApplication)
io.confluent.kafka.schemaregistry.exceptions.SchemaRegistryInitializationException: Error initializing kafka store while initializing schema registry
        at io.confluent.kafka.schemaregistry.storage.KafkaSchemaRegistry.init(KafkaSchemaRegistry.java:210)
        at io.confluent.kafka.schemaregistry.rest.SchemaRegistryRestApplication.initSchemaRegistry(SchemaRegistryRestApplication.java:61)
        at io.confluent.kafka.schemaregistry.rest.SchemaRegistryRestApplication.setupResources(SchemaRegistryRestApplication.java:72)
        at io.confluent.kafka.schemaregistry.rest.SchemaRegistryRestApplication.setupResources(SchemaRegistryRestApplication.java:39)
        at io.confluent.rest.Application.createServer(Application.java:201)
        at io.confluent.kafka.schemaregistry.rest.SchemaRegistryMain.main(SchemaRegistryMain.java:41)
Caused by: io.confluent.kafka.schemaregistry.storage.exceptions.StoreInitializationException: io.confluent.kafka.schemaregistry.storage.exceptions.StoreException: Failed to write Noop record to kafka store.
        at io.confluent.kafka.schemaregistry.storage.KafkaStore.init(KafkaStore.java:137)
        at io.confluent.kafka.schemaregistry.storage.KafkaSchemaRegistry.init(KafkaSchemaRegistry.java:208)
        ... 5 more
Caused by: io.confluent.kafka.schemaregistry.storage.exceptions.StoreException: Failed to write Noop record to kafka store.
        at io.confluent.kafka.schemaregistry.storage.KafkaStore.getLatestOffset(KafkaStore.java:422)
        at io.confluent.kafka.schemaregistry.storage.KafkaStore.waitUntilKafkaReaderReachesLastOffset(KafkaStore.java:275)
        at io.confluent.kafka.schemaregistry.storage.KafkaStore.init(KafkaStore.java:135)
        ... 6 more
Caused by: java.util.concurrent.TimeoutException: Timeout after waiting for 60000 ms.
        at org.apache.kafka.clients.producer.internals.FutureRecordMetadata.get(FutureRecordMetadata.java:78)
        at org.apache.kafka.clients.producer.internals.FutureRecordMetadata.get(FutureRecordMetadata.java:30)
        at io.confluent.kafka.schemaregistry.storage.KafkaStore.getLatestOffset(KafkaStore.java:417)
        ... 8 more

Run Code Online (Sandbox Code Playgroud)

小智 6

在 中$CONFLUENT_HOME/etc/kafka,您将看到 server.properties。

取消注释以下内容并更新如下

  1. listeners=PLAINTEXT://0.0.0.0:9092

  2. advertised.listeners=PLAINTEXT://localhost:9092

  3. listener.security.protocol.map=PLAINTEXT:PLAINTEXT,SSL:SSL,SASL_PLAINTEXT:SASL_PLAINTEXT,SASL_SSL:SASL_SSL

在 中$CONFLUENT_HOME/etc/schema-registry,您将看到 schema-registry.properties,打开并更新如下

  1. listeners=http://0.0.0.0:9092


sai*_*hna 1

我想我已经找到答案了

host.name=host_ip_address在 Kafka 配置文件中添加将充当 Kafka 代理主机的属性。因此,在 Kafka bootstrap 属性所在的所有配置文件中,将其更改为相应的主机名或 IP 地址,如下所示。

bootstrap.servers=192.168.0.193:9092
Run Code Online (Sandbox Code Playgroud)

示例:在架构注册表配置中,我已将以下属性从本地主机更改为相应的 IP 地址

kafkastore.bootstrap.servers=PLAINTEXT://192.168.0.193:9092 ##
Run Code Online (Sandbox Code Playgroud)

在其他文件中检查属性bootstrap.servers=192.168.0.193:9092是否正确引用。还要检查架构注册表配置文件是否正确引用。

(其实你可以在kafka日志中查看和比较配置文件/tmp/confluent)

现在,更改所有配置文件后,服​​务即可启动并运行。