我安装了 RabbitMQ,它运行良好。然后,一旦我的系统内存已满并且它停止工作。我清除了系统内存并再次启动了RabbitMQ,但它没有启动。以下是我得到的状态。
root@qa-development-vm:/usr/# systemctl status rabbitmq-server.service
? rabbitmq-server.service - RabbitMQ broker
Loaded: loaded (/lib/systemd/system/rabbitmq-server.service; enabled)
Active: activating (start) since Thu 2018-12-06 06:13:31 UTC; 641ms ago
Process: 32243 ExecStop=/bin/sh -c while ps -p $MAINPID >/dev/null 2>&1; do sleep 1; done (code=exited, status=0/SUCCESS)
Process: 32105 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
Main PID: 32253 (beam.smp)
CGroup: /system.slice/rabbitmq-server.service
??32253 /usr/lib/erlang/erts-10.1.3/bin/beam.smp -W w -A 64 -P 1048576 -t 5000000 -stbt db -zdbbl 128000 -K true -- -root /usr/lib/erlang -progname erl -- -home ...
??32465 erl_child_setup 1024
root@qa-development-vm:/usr/# journalctl -xn
-- Logs begin at Thu 2018-12-06 05:00:15 UTC, end at Thu 2018-12-06 06:13:46 UTC. --
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: * connected to epmd (port 4369) on qa-development-vm
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: * epmd reports: node 'rabbit' not running at all
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: no other nodes on qa-development-vm
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: * suggestion: start the node
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: current node details:
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: - node name: 'rabbitmq-cli-90@qa-development-vm'
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: - home dir: /var/lib/rabbitmq
Dec 06 06:13:46 qa-development-vm rabbitmqctl[400]: - cookie hash: mF/Qt8msGSizqNbONVAZQw==
Dec 06 06:13:46 qa-development-vm systemd[1]: Failed to start RabbitMQ broker.
-- Subject: Unit rabbitmq-server.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit rabbitmq-server.service has failed.
--
-- The result is failed.
Dec 06 06:13:46 qa-development-vm systemd[1]: Unit rabbitmq-server.service entered failed state.
Run Code Online (Sandbox Code Playgroud)
我累了,但我什么也没发生。我也检查了日志,但什么也没有。我删除了所有日志并再次尝试启动服务器,但得到相同的错误并且没有生成日志文件。
我重新安装了它,它又工作了。但我想要它的原因以及如何解决它,如果再次发生。
如果大型消息存储正在填充您的磁盘,则链接文档中的解决方案是一个选项。请注意,这将导致消息丢失以及系统配置丢失:
rm -rf /var/lib/rabbitmq/mnesia/*
systemctl start rabbitmq-server
Run Code Online (Sandbox Code Playgroud)
没有提供足够的信息来进一步诊断(“我什么都没发生”没有帮助)。重新安装可能已正确删除系统配置,但无需完全重新安装即可解决此问题。
注:在RabbitMQ的团队监控的rabbitmq-users邮件列表,只有时StackOverflow上回答问题。
| 归档时间: |
|
| 查看次数: |
5869 次 |
| 最近记录: |