出现 104“连接被对等方重置”错误的一般规则是什么?

JC_*_*_CL 10 tcp http

关于网站何时发送 TCP 重置、触发Connection reset by peer?

\n\n

喜欢

\n\n
    \n
  • 打开的连接太多
  • \n
  • 带宽使用率过高
  • \n
  • 连接时间过长
  • \n
  • \xe2\x80\xa6?
  • \n
\n\n

我很确定没有法律管辖这一点,并且不同的网站/网络开发人员有不同的品味,但如果有一些通用规则集(来自有关该主题的网站或教科书或您所学的内容)我会很感兴趣在学校/工作中),这些都是大多数人遵循的。

\n\n

当然,我问的原因是我想避免被阻止\xe2\x80\xa6

\n\n

我正在下载一些免费提供的政府数据,但缺少 API 或其他东西,因此获取它的两种官方方法是在某些网络 GIS 中点击几千次,或者沿着卡夫卡式的解释路径不同级别的职员了解数据库、csv 文件、zip 文件的概念,并且您不能(也不需要,如果他们只是做了您试图解释的事情)只需开车去他们的机构一个“巨型”硬盘,所以我试图为每个参与的人采取最节省资源的方式\xe2\x80\xa6

\n

Ste*_*ich 11

网站没有“发送”“连接被对等方重置”错误。如果客户端站点上的操作系统内核针对活动连接进行了 TCP 重置,则会生成此错误。发送此 TCP 重置的原因有很多。TCP 重置可能是根据某种负载限制设计发送的,例如,作为 DOS 保护的一种形式,限制特定时间内来自同一 IP 地址的连接数量、限制数据抓取或强制实施某种公平使用。对于这种明确的限制,没有一般规则,甚至没有法律。

TCP 重置也可能是由于应用程序过载、应用程序崩溃、系统资源耗尽......引起的。

如果客户端写入服务器已认为已关闭的连接,则会发生 TCP 重置。例如,HTTP 保持活动状态可能会发生这种情况:服务器可能会在发送 HTTP 响应后随时关闭不活动的连接。如果客户端在服务器关闭连接的同时在同一连接上发送新请求,服务器将拒绝新请求(因为连接在服务器端关闭)并发送 TCP RST,导致连接重置通过客户端的同行。客户端需要通过创建新连接并再次发送请求来正确处理这种情况(前提是该请求没有状态改变,即是幂等的)。