fuz*_*zzi 6 .net ubuntu ssl-certificate jenkins
我正在使用构建服务器dotnet publish在我的.NET项目上运行以打包项目和依赖项.
我跑步时dotnet publish使用
<PackageReference Include="Microsoft.AspNetCore.All" Version="2.0.6" />
Run Code Online (Sandbox Code Playgroud)
在我的.csproj文件中,应用程序按预期运行dotnet发布.但是,当我进行更改以将AspNetCore版本增加到Version="2.0.7"它时会产生:
/usr/share/dotnet/sdk/2.1.104/NuGet.targets(104,5): error : Unable to load the service index for source https://api.nuget.org/v3/index.json.
[/{file-path}/dotnetproj.csproj]
/usr/share/dotnet/sdk/2.1.104/NuGet.targets(104,5): error : An error occurred while sending the request.
[/{file-path}/dotnetproj.csproj]
/usr/share/dotnet/sdk/2.1.104/NuGet.targets(104,5): error : Problem with the SSL CA cert (path? access rights?)
[/{file-path}/dotnetproj.csproj]
Run Code Online (Sandbox Code Playgroud)
(这是一个示例,如果我对.csproj文件中列出的包进行任何修改,例如添加新包,则会导致相同的错误.).我正在通过詹金斯运行这个命令.
有没有办法让我正确运行增量版本?它是否涉及为构建服务器更新/重新创建证书?服务器正在运行ubuntu.
任何有关此问题的帮助将不胜感激!
这似乎类似于“ Jenkins CI - SSL CA error ”及其相关dotnet/cli问题 3987(没有任何答案)
检查你的 Jenkins 代理(我假设是 Linux 代理):请参阅:
security/ca_root_nss安装),或者ca-certificates是最新的。两者都取决于运行 Jenkins 代理的操作系统。
| 归档时间: |
|
| 查看次数: |
190 次 |
| 最近记录: |