无法增加本地 WordPress 中的最大上传文件大小

erf*_*ban 5 php apache wordpress .htaccess upload

我正在使用我自己的本地主机(ubuntu 和 apache2)来运行 wordpress 4.8 。我想增加最大上传文件大小。我尝试了这些方法,但没有解决:

1.creatingphp.ini在/var/www/html或改变它/etc/php/7.0/apache2/php.ini:

upload_max_filesize = 512M
memory_limit = 512M
post_max_size = 512M
max_execution_time = 300
Run Code Online (Sandbox Code Playgroud)

2.换.htaccess入/var/www/html:

php_value upload_max_filesize 512M
php_value post_max_size 512M
php_value max_execution_time 300
php_value max_input_time 300
Run Code Online (Sandbox Code Playgroud)

3.functions.php在主题文件夹中的文件中添加以下代码行:

@ini_set('upload_max_size' , '512M');
@ini_set('post_max_size', '512M');
@ini_set('max_execution_time', '300');
Run Code Online (Sandbox Code Playgroud)

4.使用上传最大文件大小插件。这个插件改变了Maximum upload file size: 2 MB.消息,但在上传超过 2mb 的文件后HTTP error.产生了。(为了解决这个问题,我也尝试了我在网上找到的所有解决方案(例如:+、+、+)但没有任何改变。打开 wordpress 日志也帮不了我。没有任何东西!!所以我放弃了。我认为此错误的根源是此问题的错误修复)

5.修改所有文件和文件夹的权限为777。

6.在我尝试过的每次修复之后,我也重新启动了apache但没有任何改变:

$ sudo service apache2 restart
Run Code Online (Sandbox Code Playgroud)

Ata*_*nas 6

转到 C:/Xampp/php/php.ini 并找到:

memory_limit=.....M
Run Code Online (Sandbox Code Playgroud)

将其更改为:

memory_limit=10000M
Run Code Online (Sandbox Code Playgroud)

然后向下滚动到:

post_max_size=.....M
Run Code Online (Sandbox Code Playgroud)

并将其更改为:

post_max_size=9999M
Run Code Online (Sandbox Code Playgroud)

找:

file_uploads=...
Run Code Online (Sandbox Code Playgroud)

如果是写:

file_uploads=On
Run Code Online (Sandbox Code Playgroud)

向下滚动并找到

upload_max_filesize=....M
Run Code Online (Sandbox Code Playgroud)

在那里写:

upload_max_filesize=9000M
Run Code Online (Sandbox Code Playgroud)

还可以找到:

max_file_uploads=.....
Run Code Online (Sandbox Code Playgroud)

并在那里写:

max_file_uploads=10000M
Run Code Online (Sandbox Code Playgroud)

注意力!当心!“Memory_limit”应该有最大的兆字节数。接下来是“max_file_uploads”,之后是“post_max_size”,最后是“upload_max_filesize”。

如果仍然有同样的错误,让你的 .htaccess 像这样:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /your_site_name/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /your_site_name/index.php [L]
</IfModule>

# END WordPress
    # WP Maximum Execution Time Exceeded
    <IfModule mod_php7.c>
    php_value max_execution_time 300

    php_value upload_max_filesize 9000M
    php_value post_max_size 9999M
    php_value max_input_time 300

    </IfModule>
Run Code Online (Sandbox Code Playgroud)


erf*_*ban 2

我不应该php.ini在/var/www/html/. 我找到了详细/etc/php/7.0/apache2/php.ini的路径phpinfo()。所以我在这个文件中找到并更改了这些配置:upload_max_filesize、memory_limit和。post_max_sizemax_execution_time

注意:我是对的!HTTP error.上传媒体是因为这个问题修复不好。现在我可以正确上传任何媒体:)