执行后systemctl start docker,我得到:
无法启动docker.service:找不到单位.
这是输出systemctl status docker -l:
[root@HP11012078 init.d]# systemctl status docker -l
? docker.service - Docker Application Container Engine
Loaded: loaded (/etc/systemd/system/docker.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: https://docs.docker.com
Feb 09 17:04:35 HP11012078 docker[28152]: time="2017-02-09T17:04:35.104333869+08:00" level=warning msg="container 58a5c6ba6710240bb5b1fd79e4600b547cf4c882eb2ca85e15c59c1404106877 restart canceled"
Feb 09 17:04:35 HP11012078 docker[28152]: time="2017-02-09T17:04:35.113914527+08:00" level=warning msg="container d320ba5f02cdd8567893acfc62b6673a24b6c8a43ccb52342bb3470ff420230d restart canceled"
Feb 09 17:04:35 HP11012078 docker[28152]: time="2017-02-09T17:04:35.122613873+08:00" level=warning msg="container 4030daadb9481a1b96b7a5c614c8910a601f83f2dced8340f4ea4c3583e7e844 restart canceled"
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45.002120051+08:00" level=info msg="Container c13f11ce792c477d9b663c6fdbcfe9694663f7843a40540c58922893f4b41247 failed to exit within 10 seconds of signal 15 - using the force"
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45.002120421+08:00" level=info msg="Container 0457d15d8b0bc83458dd3eea0c0b84699465da9746defc2429db89e426dbfa75 failed to exit within 10 seconds of signal 15 - using the force"
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45.002870012+08:00" level=warning msg="Cannot kill container c13f11ce792c477d9b663c6fdbcfe9694663f7843a40540c58922893f4b41247: rpc error: code = 2 desc = \"containerd: container not found\""
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45.049505738+08:00" level=warning msg="container 0457d15d8b0bc83458dd3eea0c0b84699465da9746defc2429db89e426dbfa75 restart canceled"
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45.173034929+08:00" level=error msg="Force shutdown daemon"
Feb 09 17:04:45 HP11012078 docker[28152]: time="2017-02-09T17:04:45+08:00" level=info msg="stopping containerd after receiving terminated"
Feb 09 17:04:46 HP11012078 systemd[1]: Stopped Docker Application Container Engine.
Run Code Online (Sandbox Code Playgroud)
但我可以使用docker daemon命令启动docker .请帮忙
Die*_*pie 11
要解决此问题,必须创建一个丢失的文件:/usr/lib/systemd/system/docker.socket
[Unit]
Description=Docker Socket for the API
PartOf=docker.service
[Socket]
ListenStream=/var/run/docker.sock
SocketMode=0660
SocketUser=root
SocketGroup=docker
[Install]
WantedBy=sockets.target
Run Code Online (Sandbox Code Playgroud)
然后运行:
systemctl daemon-reload
systemctl start docker.socket
systemctl start docker
Run Code Online (Sandbox Code Playgroud)
然后Docker将启动.看起来安装会删除该文件而不会替换它.
只需尝试再次安装 docker,看看问题是否仍然存在:
sudo yum install docker
Run Code Online (Sandbox Code Playgroud)
然后service docker start和docker info。
如果在 CentOS 8 上安装 Docker 时遇到此错误:
在 CentOS 8.1 上,podman-manpages 与 docker-ce 冲突(podman 是 Red Hat 的容器引擎,它作为 Docker 的替代品预先安装)。
一个简单的解决方案是,如果您不需要,则卸载 podman:https :
sudo yum -y remove podman
//github.com/containers/libpod/issues/4791
然后你可以安装Docker:
sudo dnf install docker-ce --nobest -y
和
sudo systemctl daemon-reload
sudo systemctl start docker
sudo systemctl enable docker
Run Code Online (Sandbox Code Playgroud)
| 归档时间: |
|
| 查看次数: |
20443 次 |
| 最近记录: |