无法连接到Postgres的服务器

SyS*_*yBy 8 postgresql

更新Windows后,我无法连接Postgres服务器。更新之前,打开数据库没有问题。我在Postgres中的数据库也消失了。当我要创建新数据库时,显示此错误:

无法连接到服务器:无法连接到服务器:连接被拒绝(0x0000274D / 10061)服务器是否在主机“ localhost”(:: 1)上运行并在端口5432上接受TCP / IP连接?无法连接到服务器:连接被拒绝(0x0000274D / 10061)服务器是否在主机“本地主机”(127.0.0.1)上运行并在端口5432上接受TCP / IP连接?

小智 58

在 Windows 上,只需转到“服务”。启动/重启 postgresql-X64 服务。它对我有用,因为我的服务不知何故处于停止状态。


小智 17

首先按win 键+R 搜索services.msc 将打开一个窗口,在其中找到postgresql-x64-13并打开它,在该选项卡中单击启动选项对我来说,它的工作完美。


小智 11

就我而言,由于某种原因,我无法打开 pgAdmin4。我使用 Postgresql 10 和 pgAdmin4

的port在postgresql.conf是不一样的pgAdmin4 - > PostgreSQL的10 - >属性- >连接- >端口。

我修复了它并且它起作用了。检查这两个是否一致。


小智 11

  1. 转到 PgAdmin
  2. 右键单击 PostgreSQL 3.选择属性
  3. 在顶部选择连接
  4. 尝试将端口从 5433 更改为 5432,反之亦然。

并重新进入。


Fra*_*nič 6

如果您的服务器不在本地主机上,则有两项要配置:

  • 找到您postgresql.conf的服务器并将其公共IP地址添加到设置的末尾listen_addresses(用逗号分隔多个条目);如果该行已被注释掉,则取消注释(例如,使用“#”)
  • 在pg_hba.conf包含客户IP地址的行中添加一行-您可以复制包含127.0.0.1的行并仅更改IP地址

在Ubuntu上,这些文件位于中/etc/postgresql/<version>/main/。


小智 6

在 Windows 上安装后立即面临这个问题。在启动时 pgAdmin 给出了这个错误,这意味着服务器没有运行。对我来说,解决方案是:开始 -> 控制面板 -> 管理 -> 服务 -> postgresql-x64-12 - 启动或重新启动


Nit*_*ain 6

发生这种情况是因为我安装了两个版本的 Postgres(v12 和 v13)。后来安装了 Psql 12,因此获得了端口 5433。我需要使用 Postgres 12。要修复此特殊情况:

  • 转到 Program Files/Postgres/<required_version>/data

    打开postgresql.conf文件

    搜索Port端口号并将其更改为 5432。

  • 打开 Windows 服务(按Cmd + R然后键入services.msc)

  • 停止您不需要的版本的服务(您可以通过右键单击 > 属性菜单永久停止它。)

  • 启动您想要的版本的服务。


小智 5

在 Windows 上,只需转到“服务”。启动/重启 postgresql-X64 服务。它对我有用,因为我的服务不知何故处于停止状态。

为我工作


Mac*_*ace 5

摘要:有2种解决方案:

  1. 打开Services并确保它postgresql-x64-14正在运行。

  2. 转到C:\Program Files\PostgreSQL\14\data并用记事本打开postgresql.conf,找到并更改port为eg 5432,然后打开Services并重新启动postgresql-x64-14。