为什么nginx启动失败?

dav*_*vid 4 nginx

然而启动 nginx 失败,我的日志显示:

[emerg] 55#55: "server" directive is not allowed here in /etc/nginx/nginx.conf:1
Run Code Online (Sandbox Code Playgroud)

我究竟做错了什么?不确定这是否重要,但这是在 docker 容器内。

jet*_*com 11

首先尝试调试

sudo nginx -t
Run Code Online (Sandbox Code Playgroud)

如果此过程通过但 nginx 重新启动失败,请尝试检查 nginx 日志以缩小错误范围

/var/log/nginx/error.log
Run Code Online (Sandbox Code Playgroud)