如何解决Nginx"proxy_pass 502 Bad Gateway"错误

use*_*367 5 nginx x509certificatevalidator

我试图在我的nginx.conf文件中添加proxy_set_header.当我尝试添加proxy_pass并调用URL时,它会抛出502 Bad Gateway nginx/1.11.1错误.

不确定如何解决此错误:

upstream app-server {
    # connect to this socket
    server unix:///tmp/alpasso-wsgi.sock;    # for a file socket
}

server {
    server_name <name>;

    listen 80 default_server;

    # Redirect http to https
    rewrite ^(.*) https://$host$1 permanent;
}

server {
    server_name <name>;

    listen 443 ssl default_server;

    recursive_error_pages on;

    location /azure{
        proxy_pass http://app-server;
    }

    ssl on;
    ssl_certificate      /etc/nginx/server.crt;
    ssl_certificate_key  /etc/nginx/server.key;
    ssl_client_certificate /etc/nginx/server.crt;
    ssl_verify_client optional;
}
Run Code Online (Sandbox Code Playgroud)

小智 6

对于proxy_pass也有类似的问题,如果您的Linux服务器使用的是SELINUX,那么您可能想尝试一下。

setsebool -P httpd_can_network_connect true
Run Code Online (Sandbox Code Playgroud)

请参阅沃伦的答案:https : //unix.stackexchange.com/questions/196907/proxy-nginx-shows-a-bad-gateway-error


Sat*_*tys 2

502当您的上游无法访问时发送。

尝试打开error log,您可能会看到failed to connect to upstream,为此您需要检查您的upstream服务器是否正在运行,sudo service upstream status然后尝试打开它。