使用IIS部署asp.net核心网站时出现502.5错误

Tor*_*y E 5 iis asp.net-core

我有一个ASP.NET Core 1.0应用程序已成功部署并在我们的预生成服务器上运行了几个月.今天我尝试使用本文作为指南将网站部署到我们的生产服务器:https: //docs.asp.net/en/latest/publishing/iis.html

底线是我们无法通过这个错误:

HTTP Error 502.5 - Process Failure

Common causes of this issue:
* The application process failed to start
* The application process started but then stopped
* The application process started but failed to listen on the configured port
Run Code Online (Sandbox Code Playgroud)

我们尝试了本文中列出的想法,但仍然没有运气: IIS上的ASP.NET Core 1.0错误502.5

你如何调试502.5错误,以找到失败的实际原因?

应用程序的日志文件正在创建,但不幸的是它们是空的.Web服务器的事件查看器包含以下条目:

Process was created with commandline 'D:\Applications\PVP\UserInterface.exe' but failed to get the status, errorCode = 0x80070005
Run Code Online (Sandbox Code Playgroud)

任何帮助将非常感谢!保守党.

Ste*_*ank 2

我一直在 .NET Core 2.0 站点上遇到这个问题,当我意识到 IIS 需要服务器上的 web.config 时,我就克服了它。

这是我的文件,对我来说关键元素是 processPath 和参数。

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <system.webServer>
<handlers>
  <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
</handlers>
<aspNetCore processPath="dotnet" 
    arguments=".\My App.dll" 
    stdoutLogEnabled="true" 
    stdoutLogFile=".\logs\stdout" />
  </system.webServer>
</configuration>
Run Code Online (Sandbox Code Playgroud)