Elasticsearch服务不在Ubuntu 16.04上的statup上运行

use*_*029 7 service startup elasticsearch ubuntu-16.04

我在Ubuntu 16.04上安装了elasticsearch.

当我进入时sudo service elasticsearch start,一切正常.

但该服务并未在启动时运行.在手动启动之前,sudo service elasticsearch status给我:

elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vend
   Active: inactive (dead)
     Docs: http://www.elastic.co
Run Code Online (Sandbox Code Playgroud)

我尝试将它添加到启动时使用: sudo update-rc.d elasticsearch defaults和sudo update-rc.d elasticsearch enable,但这没有任何改变.

可能是什么问题,我该如何调试?

Nev*_*eue 9

您的问题的答案是运行:

sudo systemctl enable elasticsearch.service
Run Code Online (Sandbox Code Playgroud)

Elasticsearch在Ubuntu 16.04使用SystemD没有System V了.

由于某些原因(截至2016年1月9日)您从APT安装ES 5.1(不确定其他版本是否受到影响),默认情况下此服务无法启动.


use*_*029 -2

没有发现错误。刚刚用dpkg重新安装了它。有效,并且数据和配置尚未被覆盖。