Bar*_*cki 4 iptables ansible centos7
如何从Ansible重启iptables服务(为了重新加载配置文件/etc/sysconfig/iptables)
我把处理程序restart iptables定义为
service: name=iptables enabled=yes state=restarted
Run Code Online (Sandbox Code Playgroud)
但它会产生以下错误消息:
致命:[xx.xx.xx.xx]:失败!=> {"已更改":false,"failed":true,"msg":"无法停止iptables.service:需要进行交互式身份验证.\n无法启动iptables.service:需要进行交互式身份验证.\n"}
我正在努力 CentOS Linux release 7.2.1511 (Core)
我没有以root身份运行我的处理程序命令.如果处理程序包含, become: yes则处理程序正常
- name: restart iptables
become: yes
service: name=iptables enabled=yes state=restarted
Run Code Online (Sandbox Code Playgroud)
另一种刷新iptables配置的方法,无需重新启动它
- name: reload iptables
become: yes
shell: iptables-restore < /etc/sysconfig/iptables
Run Code Online (Sandbox Code Playgroud)
| 归档时间: |
|
| 查看次数: |
11573 次 |
| 最近记录: |