Kal*_*lle 8 mysql mysql-workbench
是否可以与 MySql Workbench 中的 local-infile 选项连接?像这样:
mysql -h 10.152.xx.xx -u USER -p --local-infile MyDatabase
Run Code Online (Sandbox Code Playgroud)
原因是 LOAD DATA LOCAL INFILE 似乎只适用于这个选项。即使
SHOW GLOBAL VARIABLES LIKE 'local_infile';
Run Code Online (Sandbox Code Playgroud)
返回
'local_infile', 'ON'
Run Code Online (Sandbox Code Playgroud)
LOAD DATA LOCAL INFILE 产生
Error Code: 1148. The used command is not allowed with this MySQL version
Run Code Online (Sandbox Code Playgroud)
这不起作用是自 Workbench 8.0.12 以来经过验证的错误。来自错误评论的解决方案:
服务器和客户端都可以限制对 LOAD DATA 和 LOAD XML 使用 LOCAL 关键字。如果其中任何一个阻止它,则会产生相同的错误消息。
要使服务器允许访问,请使用 设置 local_infile 变量
SET GLOBAL local_infile = 1;或检查它SHOW GLOBAL VARIABLES LIKE 'local_infile';。或者,编辑 mysql 的配置以包含local_infile=1.要使 Workbench 允许访问,请编辑连接(单击 MySQL Connections 旁边的扳手图标,或右键单击特定连接并选择 Edit Connection...)。在“高级”选项卡上的“其他:”框中,添加行
OPT_LOCAL_INFILE=1
我刚遇到这个问题并设置变量以及 MySQL Workbench 配置解决了它。
| 归档时间: |
|
| 查看次数: |
8965 次 |
| 最近记录: |