在AWS EC2上重新启动httpd的行为不正常.它应该删除/ var/www/html的内容吗?

gdg*_*dgr 3 php apache wordpress amazon-ec2 amazon-web-services

正如标题所说,我在Amazon Web Services上的EC2实例(弹性beanstalk)中托管PHP应用程序,实际上运行Wordpress连接到RDS实例.我一直需要重启apache有很多原因,主要是因为我使用的是mod_pagespeed apache模块.

我这样做时几乎没有失败,它删除了/var/www/html/使用此命令的内容:

sudo service httpd restart
Run Code Online (Sandbox Code Playgroud)

自从我刚接触AWS以来,我有点亏,但这显然不是理想的功能.还有其他方法我应该重新启动apache吗?任何人都可以解释为什么会这样吗?

任何欢迎的建议,我觉得我必须与大多数管理员握手,但这对我来说只是一个令人头疼的问题!

cno*_*eld 5

我不确定删除内容会发生什么,但您可以尝试使用graceful命令重新启动.

sudo apache2ctl graceful
Run Code Online (Sandbox Code Playgroud)

这将优雅地重新加载其配置!

或重装命令

sudo service httpd reload
Run Code Online (Sandbox Code Playgroud)

  • 怎么样`sudo service httpd graceful`? (2认同)