获取在mac OS X Yosemite上运行的localhost

Xav*_*ver 19 php mysql apache osx-yosemite

我已经将我的操作系统更新到Yosemite,我唯一的问题是我的本地主机不再工作了.如果问题听起来很愚蠢,但我对服务器的了解有限,请原谅.

与小牛我能够使用localhost和customdomain.dev正确的系统启动之后.我的MySQL服务器也已启动,没有任何操作

现在,Google Chrome ERR_CONNECTION_REFUSED在使用localhost时会抛出错误.

我跑

apachectl configtest
Run Code Online (Sandbox Code Playgroud)

返回

httpd: Syntax error on line 58 of /private/etc/apache2/httpd.conf: Cannot load libexec/apache2/mod_authn_default.so into server: dlopen(/usr/libexec/apache2/mod_authn_default.so, 10): image not found
Run Code Online (Sandbox Code Playgroud)

如果我注释掉这一行,它会继续其他模块.当我注释掉导致这种语法错误的所有模块时,我得到了

AH00526: Syntax error on line 131 of /private/etc/apache2/httpd.conf:
Invalid command 'User', perhaps misspelled or defined by a module not included in the server configuration
Run Code Online (Sandbox Code Playgroud)

我正在使用httpd.confMavericks 的文件(一切正常)

我不知道接下来该做什么

Ste*_*mer 35

你是否在升级之前保留了原来的httpd.conf?您可能需要编辑httpd.conf中的模块

我发现与Yosemite一起进行了Apache升级.显然,从Apache 2.2到2.4有几个与身份验证相关的更改.我不得不sudo apachectl configtest反复运行以显示要删除的模块.

然后,我不得不添加一些模块.我的模块现在看起来像这样:

LoadModule authn_file_module libexec/apache2/mod_authn_file.so
LoadModule authn_dbm_module libexec/apache2/mod_authn_dbm.so
LoadModule authn_anon_module libexec/apache2/mod_authn_anon.so
LoadModule authn_dbd_module libexec/apache2/mod_authn_dbd.so
#LoadModule authn_default_module libexec/apache2/mod_authn_default.so
LoadModule authn_core_module libexec/apache2/mod_authn_core.so
LoadModule authz_host_module libexec/apache2/mod_authz_host.so
LoadModule authz_groupfile_module libexec/apache2/mod_authz_groupfile.so
LoadModule authz_user_module libexec/apache2/mod_authz_user.so
LoadModule authz_dbm_module libexec/apache2/mod_authz_dbm.so
LoadModule authz_owner_module libexec/apache2/mod_authz_owner.so
#LoadModule authz_default_module libexec/apache2/mod_authz_default.so
LoadModule authz_core_module libexec/apache2/mod_authz_core.so
LoadModule auth_basic_module libexec/apache2/mod_auth_basic.so
LoadModule auth_digest_module libexec/apache2/mod_auth_digest.so
LoadModule cache_module libexec/apache2/mod_cache.so
#LoadModule disk_cache_module libexec/apache2/mod_disk_cache.so
#LoadModule mem_cache_module libexec/apache2/mod_mem_cache.so
LoadModule dbd_module libexec/apache2/mod_dbd.so
LoadModule dumpio_module libexec/apache2/mod_dumpio.so
LoadModule reqtimeout_module libexec/apache2/mod_reqtimeout.so
LoadModule ext_filter_module libexec/apache2/mod_ext_filter.so
LoadModule include_module libexec/apache2/mod_include.so
LoadModule filter_module libexec/apache2/mod_filter.so
LoadModule substitute_module libexec/apache2/mod_substitute.so
LoadModule deflate_module libexec/apache2/mod_deflate.so
LoadModule log_config_module libexec/apache2/mod_log_config.so
LoadModule log_forensic_module libexec/apache2/mod_log_forensic.so
LoadModule logio_module libexec/apache2/mod_logio.so
LoadModule env_module libexec/apache2/mod_env.so
LoadModule mime_magic_module libexec/apache2/mod_mime_magic.so
#LoadModule cern_meta_module libexec/apache2/mod_cern_meta.so
LoadModule expires_module libexec/apache2/mod_expires.so
LoadModule headers_module libexec/apache2/mod_headers.so
#LoadModule ident_module libexec/apache2/mod_ident.so
LoadModule usertrack_module libexec/apache2/mod_usertrack.so
#LoadModule unique_id_module libexec/apache2/mod_unique_id.so
LoadModule setenvif_module libexec/apache2/mod_setenvif.so
LoadModule version_module libexec/apache2/mod_version.so
LoadModule proxy_module libexec/apache2/mod_proxy.so
LoadModule proxy_connect_module libexec/apache2/mod_proxy_connect.so
LoadModule proxy_ftp_module libexec/apache2/mod_proxy_ftp.so
LoadModule proxy_http_module libexec/apache2/mod_proxy_http.so
LoadModule proxy_scgi_module libexec/apache2/mod_proxy_scgi.so
LoadModule proxy_ajp_module libexec/apache2/mod_proxy_ajp.so
#LoadModule proxy_balancer_module libexec/apache2/mod_proxy_balancer.so
LoadModule ssl_module libexec/apache2/mod_ssl.so
LoadModule mime_module libexec/apache2/mod_mime.so
LoadModule dav_module libexec/apache2/mod_dav.so
LoadModule status_module libexec/apache2/mod_status.so
LoadModule autoindex_module libexec/apache2/mod_autoindex.so
LoadModule asis_module libexec/apache2/mod_asis.so
LoadModule info_module libexec/apache2/mod_info.so
LoadModule cgi_module libexec/apache2/mod_cgi.so
LoadModule dav_fs_module libexec/apache2/mod_dav_fs.so
LoadModule vhost_alias_module libexec/apache2/mod_vhost_alias.so
LoadModule negotiation_module libexec/apache2/mod_negotiation.so
LoadModule dir_module libexec/apache2/mod_dir.so
LoadModule imagemap_module libexec/apache2/mod_imagemap.so
LoadModule actions_module libexec/apache2/mod_actions.so
LoadModule speling_module libexec/apache2/mod_speling.so
LoadModule userdir_module libexec/apache2/mod_userdir.so
LoadModule alias_module libexec/apache2/mod_alias.so
LoadModule rewrite_module libexec/apache2/mod_rewrite.so
#LoadModule perl_module libexec/apache2/mod_perl.so
#LoadModule php5_module libexec/apache2/libphp5.so
LoadModule unixd_module libexec/apache2/mod_unixd.so
LoadModule access_compat_module libexec/apache2/mod_access_compat.so
LoadModule php5_module /usr/local/opt/php56/libexec/apache2/libphp5.so
LoadModule hfs_apple_module libexec/apache2/mod_hfs_apple.so
Run Code Online (Sandbox Code Playgroud)

你会看到我注释了一些.有一些新的.这两个_core_的,unixd_module以及access_compat_module是新的.不要介意奇怪的PHP模块.那是来自Homebrew的PHP.

我还必须删除该LockFile指令httpd-mpm.conf.和NameVirtualHost指令httpd-vhosts.conf.

我希望这有帮助.

  • 谢谢tipp.我将`/ etc/apache2/original/httpd.conf`复制到`/ etc/apache2/httpd.conf`,服务器再次运行.我必须再次为我的需要重新配置该文件,但这不是问题.谢谢! (9认同)
  • 当这个问题发生时,后悔升级到优胜美地.10分钟后,问题得到解决.祝福溢出...... (5认同)
  • 谢谢你; 我今天失去了解决这个问题的意愿.最后,我还必须添加:(1)`LoadModule authz_core_module libexec/apache2/mod_authz_core.so`来处理错误消息`无效命令'需要',可能拼写错误或由服务器配置中未包含的模块定义.请参阅:http:// http://stackoverflow.com/questions/18844338/invalid-command-require-perhaps-misspelled-or-defined-by-a-module-not-include(2)"配置文件"部分mac-dev-env.patrickbougie.com/apache/ (2认同)
  • 你是救星! (2认同)