XAMPP服务器上的MySQL无法启动。

Nad*_*han 3 mysql xampp

我正在尝试启动mysql服务器,但它给出以下错误日志。我试图更改端口号。但这不值得

2014-09-26 09:31:23 3880 [Note] Plugin 'FEDERATED' is disabled.
2014-09-26 09:31:23 f34 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2014-09-26 09:31:23 3880 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-09-26 09:31:23 3880 [Note] InnoDB: The InnoDB memory heap is disabled
2014-09-26 09:31:23 3880 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2014-09-26 09:31:23 3880 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-09-26 09:31:23 3880 [Note] InnoDB: Not using CPU crc32 instructions
2014-09-26 09:31:23 3880 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2014-09-26 09:31:23 3880 [Note] InnoDB: Completed initialization of buffer pool
2014-09-26 09:31:23 3880 [Note] InnoDB: Highest supported file format is Barracuda.
2014-09-26 09:31:23 3880 [Note] InnoDB: Log scan progressed past the checkpoint lsn 3997169
2014-09-26 09:31:23 3880 [Note] InnoDB: Database was not shutdown normally!
2014-09-26 09:31:23 3880 [Note] InnoDB: Starting crash recovery.
2014-09-26 09:31:23 3880 [Note] InnoDB: Reading tablespace information from the .ibd files...
2014-09-26 09:31:24 3880 [Note] InnoDB: Restoring possible half-written data pages 
2014-09-26 09:31:24 3880 [Note] InnoDB: from the doublewrite buffer...
InnoDB: Doing recovery: scanned up to log sequence number 3997285
2014-09-26 09:31:24 3880 [Note] InnoDB: 128 rollback segment(s) are active.
2014-09-26 09:31:25 3880 [Note] InnoDB: Waiting for purge to start
2014-09-26 09:31:25 3880 [Note] InnoDB: 5.6.16 started; log sequence number 3997285
2014-09-26 09:31:25 3880 [Note] Server hostname (bind-address): '*'; port: 3306
2014-09-26 09:31:25 3880 [Note] IPv6 is available.
2014-09-26 09:31:25 3880 [Note]   - '::' resolves to '::';
2014-09-26 09:31:25 3880 [Note] Server socket created on IP: '::'.
2014-09-26 09:31:25 3880 [ERROR] Fatal error: Can't open and lock privilege tables: Incorrect file format 'user'
Run Code Online (Sandbox Code Playgroud)

Her*_*lez 9

复制这3个文件:

  • user.frm
  • 用户名
  • 用户名

从C:\ xampp \ mysql \ backup \ mysql到C:\ xampp \ mysql \ data \ mysql

并覆盖它。


Bjo*_*ern 3

真正的问题如下所示:

2014-09-26 09:31:25 3880 [ERROR] Fatal error: Can't open and lock privilege tables: Incorrect file format 'user'
Run Code Online (Sandbox Code Playgroud)

至少其中一个表文件C:\your\xampp\mysql\data\mysql\user*似乎有缺陷。由于这对服务器至关重要,因此它无法启动。

处理这个问题的可能方法:

  • 如果安装后出现问题,请尝试重新安装。
  • 如果您最近才遇到此问题,请C:\your\xampp\mysql\data\mysql\user*从最近的备份中恢复。
  • 如果您没有备份,您甚至可以在其他地方安装另一个 mysql 实例并将文件复制C:\your\new\mysql\data\mysql\user*到C:\your\xampp\mysql\data\mysql\. 由于这仅包含默认用户,因此您必须手动添加在旧的、损坏的安装中使用过的用户。