mysql服务器无法启动MAMP

cha*_*hap 1 mysql mamp

我在这里读了几个答案,说当你的mysql服务器无法在MAMP中启动时你应该运行

sudo killall -9 mysqld 
Run Code Online (Sandbox Code Playgroud)

我过去曾经使用过它并且它已经起作用但是无论出于什么原因它这次都没有用.我在日志中收到此错误消息:

[04-May-2014 11:02:08 UTC] PHP Warning:  mysql_connect(): Can't connect to local MySQL server through socket '/Applications/MAMP/tmp/mysql/mysql.sock' (2) in /Users/Chappell/Websites/LFB/wp-includes/wp-db.php on line 1372
Run Code Online (Sandbox Code Playgroud)

我最近从我在本地开发的另一台计算机上传输了我正在处理的网站的文件(不是MAMP本身).不确定这是否相关,但我想我会指出它.

Eri*_*tke 11

我首先尝试'sudo killall -9 mysqld'并没有找到任何进程.

对我有用的是删除mysql目录中的所有文件(但不是目录):rm/Applications/MAMP/db/mysql/*