use*_*497 7 centos unixodbc freetds
CENTOS 6.5 x86_64 WHM 11.42.1 unixODBC 2.2.14
我试图连接到远程MSSQL服务器但没有成功 - 也尝试连接不同的tds版本(4.2,7.0,7.1,8.0),但都给出了相同的结果.
使用相同的服务器名称,端口,用户名和密码,我可以使用Win7和SQL Server Management Studio通过我的桌面进行连接.
Telnet也失败了.
细节如下.如果您需要,请告诉我.所有帮助/建议表示赞赏.
========
Compile-time settings (established with the "configure" script)
Version: freetds v0.91
freetds.conf directory: /etc
MS db-lib source compatibility: yes
Sybase binary compatibility: yes
Thread safety: yes
iconv library: yes
TDS version: 4.2
iODBC: no
unixodbc: yes
SSPI "trusted" logins: no
Kerberos: yes
Run Code Online (Sandbox Code Playgroud)
========
locale is "en_US.UTF-8"
locale charset is "UTF-8"
using default charset "UTF8"
20Error 20009 (severity 9):
Unable to connect: Adaptive Server is unavailable or does not exist
OS error 110, "Connection timed out"
There was a problem connecting to the server
Run Code Online (Sandbox Code Playgroud)
=======
[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source
[08S01][unixODBC][FreeTDS][SQL Server]Unable to connect: Adaptive Server is unavailable or does not exist
[ISQL]ERROR: Could not SQLConnect
Run Code Online (Sandbox Code Playgroud)
======== osql -S testDSN -U'testuser'-P'testpass'...
Configuration looks OK. Connection details:
DSN: testDSN
odbc.ini: /etc/odbc.ini
Driver: /usr/lib64/libtdsodbc.so
Server hostname: winsrv106.pleskdns.co.uk
Address: x.x.x.x
Attempting connection as testuser ...
+ isql testDSN testuser 'testpass' -v
[S1000][unixODBC][FreeTDS][SQL Server]Unable to connect to data source
[08S01][unixODBC][FreeTDS][SQL Server]Unable to connect: Adaptive Server is unavailable or does not exist
[ISQL]ERROR: Could not SQLConnect
net.c:205:FAILED Connecting to x.x.x.x port XXXX (TDS version 7.1)
Run Code Online (Sandbox Code Playgroud)
========
log.c:196:Starting log file for FreeTDS 0.91
on 2014-04-10 15:33:03 with debug flags 0x4fff.
iconv.c:330:tds_iconv_open(0x7233e0, UTF8)
iconv.c:187:local name for ISO-8859-1 is ISO-8859-1
iconv.c:187:local name for UTF-8 is UTF-8
iconv.c:187:local name for UCS-2LE is UCS-2LE
iconv.c:187:local name for UCS-2BE is UCS-2BE
iconv.c:349:setting up conversions for client charset "UTF8"
iconv.c:351:preparing iconv for "UTF8" <-> "UCS-2LE" conversion
iconv.c:391:preparing iconv for "ISO-8859-1" <-> "UCS-2LE" conversion
iconv.c:394:tds_iconv_open: done
net.c:205:Connecting to x.x.x.x port XXXX (TDS version 7.1)
net.c:270:tds_open_socket: connect(2) returned "Operation now in progress"
net.c:306:getsockopt(2) reported: Connection timed out
net.c:316:tds_open_socket() failed
util.c:331:tdserror(0x723140, 0x7233e0, 20009, 110)
util.c:361:tdserror: client library returned TDS_INT_CANCEL(2)
util.c:384:tdserror: returning TDS_INT_CANCEL(2)
mem.c:615:tds_free_all_results()
Run Code Online (Sandbox Code Playgroud)
========
Trying x.x.x.x...
telnet: connect to address x.x.x.x:
Connection timed out
Run Code Online (Sandbox Code Playgroud)
小智 5
我有同样的问题并通过使用自定义端口解决它:freetds.conf中的port = XXXXX此端口应在SQL Server配置管理中配置
SQL Server网络配置 - > TCP/IP(已启用) - > IP地址 - > IPAll - > TCP动态端口
https://msdn.microsoft.com/en-us/library/ms177440.aspx
| 归档时间: |
|
| 查看次数: |
25187 次 |
| 最近记录: |