iReport 5.5.0无法启动

BoJ*_*man 4 jvm jvm-hotspot ireport ubuntu-12.04

我想在ubuntu 12.04上使用iReport.当我尝试启动它时,它静止不动,只是给了我这个错误:

Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /tmp/jna4023560596826437553.tmp which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Run Code Online (Sandbox Code Playgroud)

我怎么解决这个问题 ?

编辑:我试过了:execstack -c /tmp/jna4023560596826437553.tmp但是没有用.

End*_*rik 7

此错误似乎与JVM问题而不是jasper有关.实际上,Linux上的Java 7具有阻止用C语言编写的代码(或其他语言,如Ruby等)并链接到Java(所谓的Java本机接口 - JNI)的功能,如果它被严重或恶意地写入,则暂停整个VM.所以,如果你使用的是java 1.7版,那么回到1.6应该可以解决问题.但是如果你想保留这个版本,那么试试干净卸载并重新安装java: Uninstall, Install

请注意,如果您没有在1.7上运行,则可能是兼容性问题.尝试匹配iReport所需的正确的jar以使其在linux上运行.