WSO2 ESB代理服务错误(传输错误:411错误:需要长度)

beh*_*zad 1 esb wso2 wso2esb

我在wso2 esb中有一个http代理服务,当我尝试这项服务时,我有一个错误如下:

<TryitProxyError xmlns:h="http://wso2.org/ns/TryitProxy" h:status="SOAP envelope     error">org.apache.axis2.AxisFault: Transport error: 411 Error: Length      Required</TryitProxyError>
Run Code Online (Sandbox Code Playgroud)

但是当在soapUI中尝试这个服务回复时...

Lak*_*tta 7

这是因为您的后端服务需要Content Length标头.请在发送调解器之前在inSequence中添加以下属性.理想情况下,应在将消息发送到后端之前添加.

<property name="DISABLE_CHUNKING" scope="axis2" value="true"/> 
Run Code Online (Sandbox Code Playgroud)