几天后Jenkins停止提供静态文件

Dir*_*nry 5 caching jetty jenkins

我运行Jenkins进行持续集成,我遇到了以下问题.几天之后,Jenkins运行得很好,静态文件的URL停止提供,并且Jenkins的CSS,JavaScript和全局外观在实际按预期运行作业时看起来很糟糕.

知道为什么吗?

URL示例:

http://myserver:8181/static/70f4ebef/css/style.css
Run Code Online (Sandbox Code Playgroud)

响应:

HTTP ERROR 404

Problem accessing /static/70f4ebef/css/style.css. Reason:

    Not Found
Powered by Jetty://
Run Code Online (Sandbox Code Playgroud)

调用http://myserver:8181/safeRestart修复了问题所以我想知道它是Jenkins问题还是Jetty/Jenkins缓存冲突.

我运行Jenkins 1.537.

小智 4

发生这种情况是因为静态资源被解压到 /tmp 目录中,并且其他东西正在清理其中早于 x 天的文件。

有关更多信息,请参阅Jenkins 问题 17526 。