我正在本地开发一个相当基本的CMS,由于权限问题无法进行ftp。我在 XAMPP 中运行 FileZilla FTP服务器,可以毫无问题地连接,但当我的代码尝试通过 ftp 上传时收到错误“550 Permission Denied”。
我尝试通过我的 FileZilla FTP客户端更改权限,但没有成功(可能是因为它是 Windows 错误:“504 命令未针对该参数实现”)。我还尝试转到目标文件夹的属性 --> 安全性 --> 权限并检查 XAMPP 运行时的用户的“完整”。
那么如何设置权限以允许我的 CMS 在 XAMPP 中使用 ftp?
终于想通了。对于遇到此问题的其他人,无需在 Windows 中设置权限。相反,在 FileZilla FTP 服务器管理界面上选择编辑 --> 用户 --> 共享文件夹并选中“写入”。
| 归档时间: |
|
| 查看次数: |
13427 次 |
| 最近记录: |