Apache2无法启动

Rya*_*ing 6 linux apache ubuntu webserver webmin

我已经用webmin在旧电脑上设置了ubuntu服务器.我不知道发生了什么,但我重新启动了服务器,当它启动它时,现在得到这个,当Apache尝试启动时.

 * Starting web server apache2
apache2: Syntax error on line 237 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/000-default: No such file or directory
Action 'start' failed.
The Apache error log may have more information.
Run Code Online (Sandbox Code Playgroud)

我已在此行检查此文件,它看起来像这样:

# Include the virtual host configurations:
Include sites-enabled/
Run Code Online (Sandbox Code Playgroud)

我已经删除了Apache并重新安装它但不确定为什么它仍然失败.

ems*_*rth 4

正如 Qben 所回答的那样,问题是启用站点的文件夹中的符号链接无效。删除损坏的符号链接并添加有效的符号链接将解决该问题。