Faye 制作中的设置

Bar*_*acs 3 ruby ruby-on-rails faye cloud66

我已经在本地主机上设置了 Faye,并且工作正常。

我现在尝试使用 Cloud66 部署服务将其部署在 DigitalOcean VPS 上。为了运行该命令,我使用“after_rails”挂钩。

rackup $RAILS_STACK_PATH/faye.ru -s Thin -E 生产

这给了我错误:

部署期间出错:after_rails 挂钩期间出错:服务器:not_specified。无法运行命令:/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in require': cannot load such file -- faye (LoadError) from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire' 来自 /var/deploy/anabol/web_head/current/faye.ru:1:in block in <main>' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:55:in/usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:55:in initialize' from /var/deploy/anabol/web_head/current/faye.ru:innew'中的instance_eval'来自/var/deploy/anabol/web_head/current /faye.ru:in <main>' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:49:ineval' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:49:in new_from_string' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/builder.rb:40:inparse_file' from /usr/local /lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/server.rb:277:in build_app_and_options_from_config' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/server.rb:199:inapp' 来自 /usr/local/lib/ruby/gems/1.9.1/gems/ rack-1.5.2/lib/rack/server.rb:314:in wrapped_app' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/server.rb:250:instart' 从 /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/lib/rack/server.rb :141:in start' from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.5.2/bin/rackup:4:in'来自 /usr/local/bin/rackup:23:in load' from /usr/local/bin/rackup:23:in'

github 仓库: https: //github.com/gwuix2/anabol

有什么建议可能是什么问题吗?不知道从哪里开始。

Phi*_*erg 5

我写了一些关于如何解决这个问题的文档,以防其他人遇到这个问题。您可以在这里找到它:http ://community.cloud66.com/articles/faye-on-cloud-66

免责声明:我在 Cloud 66 工作。