我有一个在私有子域上运行的服务器,server.internal.example.com
example.com是公开的但internal.example.com不是。
我已使用 CertBot 生成证书,*.example.com但如果我尝试扩展此证书以包含*.internal.example.comDNS 质询,则会失败,因为 LetsEncrypt 无法访问此域。我尝试过运行两者:
sudo certbot certonly --manual --preferred-challenges=dns -d *.example.com -d *.internal.example.com
sudo certbot certonly --manual --preferred-challenges=dns -d *.example.com -d server.internal.example.com
Run Code Online (Sandbox Code Playgroud)
但这都要求我进行 LetsEncrypt 无法看到的 DNS 记录更改。有没有办法解决?