我在服务器(硬件 Raid 1)中有一个 SCSI 磁盘,32G,ext3 文件系统。df告诉我磁盘已 100% 已满。如果我删除 1G,这将正确显示。
但是,如果我运行 adu -h -x /然后du告诉我只使用了 12G(我使用-x是因为一些 Samba 安装)。
所以我的问题不是关于 du 和 df 命令之间的细微差别,而是关于我如何找出造成这种巨大差异的原因?
我为 fsck 重新启动了机器,但没有错误。我应该跑badblocks吗?lsof向我显示没有打开的已删除文件,lost+found是空的,并且消息文件中没有明显的警告/错误/失败语句。
请随时询问有关设置的更多详细信息。
我有一个文件服务器,其中 df 报告 94% 的 / 已满。但是根据 du 的说法,使用的要少得多:
# df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/sda3 270G 240G 17G 94% /
# du -hxs /
124G /
Run Code Online (Sandbox Code Playgroud)
我读到打开但删除的文件可能对此负责,但重新启动并没有解决这个问题。
这是Linux,ext3。
问候
可能的重复:
Linux 的 df 和 du 的根分区大小不同
在 Ubuntu 12.04 服务器上,普通用户无法再在 中创建或添加文件/home,遇到“设备上没有剩余空间”错误。
该/home目录的容量为 1.7 TB,据我所知,在存储的实际数据或使用的 inode 方面还远远不够。
df -h 显示:
Filesystem Size Used Avail Use% Mounted on
/dev/md2 1.0T 18G 955G 2% /
udev 7.7G 4.0K 7.7G 1% /dev
tmpfs 3.1G 320K 3.1G 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 7.7G 0 7.7G 0% /run/shm
cgroup 7.7G 0 7.7G 0% /sys/fs/cgroup
/dev/md3 1.7T 1.7T 0 100% /home
/dev/md1 496M 45M 426M 10% /boot
Run Code Online (Sandbox Code Playgroud)
/home …
df -h
Filesystem Size Used Avail Use% Mounted on
udev 1.9G 12K 1.9G 1% /dev
tmpfs 391M 1.2M 389M 1% /run
/dev/sda6 19G 17G 597M 97% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 2.0G 352K 2.0G 1% /run/shm
none 100M 64K 100M 1% /run/user
/dev/sda4 372G 35G 338G 10% /media/shreya/FED815A3D8155AEB
/dev/sda5 453M 36M 390M 9% /media/shreya/c76b5210-3463-43b2-8b4a-8f5b62fdd868
Run Code Online (Sandbox Code Playgroud)
我试图从 ubuntu 14.04 升级到 ubuntu 16.04,但由于磁盘空间不足而被中止。我希望释放 / 中的磁盘空间,根据上面的磁盘空间使用情况,该空间已使用 97%。我尝试过 sudo apt-get clean 和 sudo apt-get autoremove,但没有任何帮助。
可能重复:
没有可用磁盘空间
我有一个 linux 服务器,它报告它的磁盘已满,但据我所知 - 磁盘未满,adf -h显示:
/dev/mapper/VolGroup00-LogVol00<br>
19G 18G 0 100% /
/dev/xvda1 99M 27M 67M 29% /boot
tmpfs 1.1G 0 1.1G 0% /dev/shm
/dev/mapper/VolGroup01-LogVol02 58G 7.5G 48G 14% /mnt/somewhere
Run Code Online (Sandbox Code Playgroud)
这是一个虚拟服务器(使用 Xencenter),上面安装了 2 个驱动器,20GB 和 40GB。如果我查看 / 我只能看到大约 12GB 正在使用,那么其余的都去哪儿了?