问题列表 - 第4906页

AWS EC2 状态检查显示“实例可达性检查失败”并出现内核恐慌

我重新启动了我的 Centos 7 实例,然后进行了启动/停止,现在我收到状态检查错误,指出该实例无法访问。我创建了该卷的快照和映像,并重新创建了一个具有额外 4GB 空间的新实例,但仍然遇到同样的问题。

我还再次分离并附加了该卷,但它仍然不起作用。结果我现在无法访问网站。

实例显示其正在运行,但状态检查显示其无法访问。我也无法通过 SSH 连接到服务器。任何人都可以建议可能是什么问题吗?

日志:

Error: Instance reachability check failed at July 19...
Error log: kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)
Instance ID: i-069eecb6048260c51
Log: https://postimg.cc/image/9wa1is2ct/
Run Code Online (Sandbox Code Playgroud)

kernel amazon-ec2

5
推荐指数
1
解决办法
2万
查看次数

在 Azure AD 中,是否可以更改 Windows 10 设备的所有者?

在 Azure AD 中,是否可以更改设备的所有者,如果可以,如何更改?

azure-active-directory windows-10

2
推荐指数
1
解决办法
2万
查看次数

站点感知集群将虚拟机迁移到随机节点,而不是首选站点

我们有 2 个物理主机、4 个虚拟节点(HyperV 服务器 VM,每个主机上有 2 个)集群,它们运行一些嵌套的测试 VM(使用提到的 HyperV 服务器)。

简而言之,它是一个实验室环境,我们试图在其中复制 2 个机架(其中每个机架是物理主机)、4 个服务器站点感知故障转移集群。我们已将 iSCSI 卷挂载到作为 CSV 工作的所有节点,其中存储了 VM。我们创建了故障域,其中前 2 个节点位于站点 1 机架 1,左侧 2 个节点位于站点 2 机架 2,将首选站点配置为站点 1。将 VM 的 Get-ClusterGroup 更改为站点 1。


问题是- 在尝试测试故障转移时,VM 迁移到随机站点,而不是首选站点 1 节点。这是为什么?它是否与存储有关?(因为所有节点都使用相同的 CSV,我们必须实现存储副本)。我错过了什么吗?

cluster hyper-v high-availability storage-spaces

4
推荐指数
1
解决办法
85
查看次数

为什么当 dig 找到主机时,postfix 会显示“Helo 命令被拒绝:找不到主机”?

所以我看到下面的错误Helo command rejected: Host not found;/var/log/syslog,但是当我做正向和反向查找有问题的主机,DNS记录似乎是合理的。有问题的邮件服务器endor,似乎可以正常接收邮件。

为什么 Postfix 会这么说(还有第二个问题,我应该更改设置来修复它吗?

因隐私而更改的电子邮件地址:

Jul 20 23:35:20 endor postfix/smtpd[1503]: NOQUEUE: reject: RCPT from
bdmrob01-2.metavante.com[206.71.18.21]: 450 4.7.1
<bdmrob02.metavante.com>: Helo command rejected: Host not found;
from=<bbankingonline@mybank.com>
to=<myemail@fqdn.org> proto=ESMTP
helo=<bdmrob02.metavante.com>
Run Code Online (Sandbox Code Playgroud)

但是 DNS 看起来不错:

endor% dig bdmrob01-2.metavante.com

; <<>> DiG 9.11.3-1ubuntu1.1-Ubuntu <<>> bdmrob01-2.metavante.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32487
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; …
Run Code Online (Sandbox Code Playgroud)

domain-name-system email postfix

7
推荐指数
1
解决办法
4551
查看次数

Kubernetes Ingress:如何在一条路径上公开两个端口?

我有一个 GCE Ingress 配置并在端口 443 上使用 SSL。我试图让端口 28080 指向我的独立可操作服务器

我目前为我的 Ingress yaml 准备了这个:

# web-ingress.yaml
apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: gke-ingress
  annotations:
    kubernetes.io/ingress.class: "gce"
    ingress.kubernetes.io/ssl-redirect: "true"
    kubernetes.io/ingress.allow-http: "false"
spec:
  rules:
  - host: example.com
    http:
      paths:
      - path: /ws
        backend:
          serviceName: websocket
          servicePort: 28080
  tls:
  - secretName: gkecert
    hosts:
    - example.com
  backend:
    serviceName: web
    servicePort: 443
Run Code Online (Sandbox Code Playgroud)

如果我将 websocket 服务的路径设置为 /,它会破坏根路径(错误 503)。从我读过的内容来看,入口无法处理一条路径上的 2 个端口。那么人们如何将他们的前端连接到 websocket 服务器而不用路径分隔呢?

kubernetes websocket google-kubernetes-engine

5
推荐指数
1
解决办法
6021
查看次数

为子域启用跨源

我有 2 个子域,av.xyz.example并且video.xyz.example. 我想为video.xyz.exampleon启用 CORS av.xyz.example

我在apache配置文件中添加了以下代码片段av.xyz.com

Header set Access-Control-Allow-Origin "video.xyz.example"`
Run Code Online (Sandbox Code Playgroud)

但我收到以下错误

“Access-Control-Allow-Origin”标头包含无效值“video.xyz.example”。因此,不允许访问来源“ https://video.xyz.example ”。

我尝试使用它来执行此操作*,但仍然收到错误,表示不允许使用通配符,尝试使用 - 执行此操作,^(.*\.xyz\.example)$但仍然收到错误,无效值。

在我的场景中正确的值应该是多少?

.htaccess apache2

5
推荐指数
2
解决办法
3万
查看次数

nginx proxy_pass 一个文件

我有一个文件,我想显示为托管,但我没有。所以我在我的 nginx 服务器块中写了这个:

location /d-p27.js {
  proxy_pass https://data.example.com/p/piwik.js;
}
Run Code Online (Sandbox Code Playgroud)

重新加载 Nginx 的配置后,当我用 测试它时curl -I https://another.example.com/d-p27.js,我得到 404。 Nginx 日志没有说更多。

所以我试试这个:

location /d-p27.js {
  rewrite ^/d-p27.js$ /p/piwik.js break;
  proxy_pass https://data.example.com/;
}
Run Code Online (Sandbox Code Playgroud)

这也是404的。有什么建议?

解决方案

感谢@RichardSmith,解决方案只是使用精确匹配来避免与其他正则表达式混淆:

location = /d-p27.js {
  proxy_pass https://data.example.com/p/piwik.js;
}
Run Code Online (Sandbox Code Playgroud)

nginx proxypass

5
推荐指数
0
解决办法
5523
查看次数

如何使用 Tomcat 和 iptables 从端口 80 重定向到端口 8443

我有以下 iptable 条目:

REDIRECT   tcp  --  anywhere             anywhere             tcp dpt:http redir ports 8443
Run Code Online (Sandbox Code Playgroud)

在我的 server.xml 中,我只有以下连接器:

<Connector port="8443" maxHttpHeaderSize="8192"
                   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" scheme="https" secure="true"
                   clientAuth="false" sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2" SSLEnabled="true"
                   URIEncoding="UTF-8" keyAlias="tomcat" keystorePass="pass" keystoreFile="/home/myhome/.keystore" />
Run Code Online (Sandbox Code Playgroud)

当我使用来自 Firefox 的 http 说时,我看到一个对类型为 application/octet-stream 的小(7 字节)文件的 GET 请求,而不是使用 https 时我将获得的页面。我正在使用 Ubuntu 18 和 Tomcat 8。

如何配置将 http 重定向到 https?

linux tomcat redirect

-2
推荐指数
1
解决办法
6437
查看次数

在 SQL Server 2012 中设计 2 个 Always On 组之间的复制

我使用的是 MS SQL Server 2012 版本。我有 2 个 Always on 组,1 个在 DC,另一个在 DR。如何在 DC 和 DR 的数据库之间设置复制。

我研究了 Distributed Always on Availability Group 仅从 2016 版本开始可用。

非常感谢您的帮助。

replication

4
推荐指数
1
解决办法
28
查看次数

在 IE 而不是 Edge 中打开的本地 Intranet 区域站点

在我们的企业 Windows 环境中,我们已经开始使用 Microsoft 的云产品。我们遇到的一个问题是 login.microsoftonline.com 在登录时总是从 Edge 切换到 IE。

EnterpriseMode 在环境中启用,但是 login.microsoftonline.com 不在 EnterpriseMode 站点列表中。当站点在 EnterpriseMode 中打开时,我们可以在 IE 的工具菜单中看到它,但 login.microsoftonline.com 不是这种情况。

但是,*.microsoftonline.com 位于本地 Intranet 区域中。

是否有使本地 Intranet 区域的行为类似于 EnterpriseMode 的 GPO?

internet-explorer-11 windows-10

6
推荐指数
1
解决办法
1857
查看次数