语境
我已经在 Debian 机器上成功安装了 DNSMasq,一切似乎都在工作。这是我所做的:
安装 DNSMasq sudo apt-get install dnsmasq
/etc/dnsmasq.d/home.dns使用以下内容更新文件:
# General configuration
domain-needed
bogus-priv
domain=dummy.home
dhcp-range=192.168.0.10,static,48h
dhcp-option=3,192.168.0.1
# Device IPs
dhcp-host=00:00:5e:00:52:41,desktop,192.168.0.10
dhcp-host=00:00:5e:00:52:12,android,192.168.0.11
Run Code Online (Sandbox Code Playgroud)
192.168.0.1 是我的 ISP 路由器的 IP。
sudo service dnsmasq restart这一切都很棒,但我是网络新手,有很多问题:
DNSMasq 如何与路由器通信?我的意思是,它如何告诉路由器它应该从那时起开始使用 DNSMasq 的 DHCP 服务器?是否有特定的协议,即 DNSMasq 与路由器通信,还是 DHCP 本身?
为什么我不必配置我的设备(安卓手机和台式电脑)来使用 DNSMasq 的 DNS 服务器?[这个问题的答案可能和上面那个问题的答案一样,但无论如何……]
有没有办法只将 DNSMasq 用于 DNS 并让路由器的 DHCP 服务器“与”或“使用”DNSMasq 的 DNS 服务器?这样我就不需要关闭路由器的 DHCP 服务器了。
正如我所说,我是一个新手,但我无法在网络上的任何地方找到这些问题的答案。
ITNOA
我有两台 SuperMicro 服务器并安装ESXI 6.0.0在它们上面并使用它们创建 vSAN 并将所有 VM 安装在vsanStorage. 并且他们每个人都有两个带 RAID 1 的 SSD 存储和两个带 RAID 1 的 HDD。在我的数据中心断电后,一台服务器中的所有 VM 都是孤立的,而另一台服务器中的所有 VM 都无法访问。在对问题进行了一些调查后,我发现我的一台服务器无法初始化 VSAN,并出现许多错误,如下所示:
865)CMMDS: MasterAddNodeToMembership:4982: Added node 5777c24c-2568-7ec6-4dd8-005056bb8703 to the cluster membership
0:07:29.240Z cpu27:34329)VSAN Device Monitor: Checking VSAN device latencies and congestion.
519)ScsiDeviceIO: 2651: Cmd(0x439e17f1ca00) 0x1a, CmdSN 0x1 from world 34314 to dev "naa.600304801cb841001f08f1ce0cfa04ce" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
519)ScsiDeviceIO: 2651: Cmd(0x439e17f1ca00) 0x1a, CmdSN 0x2 from world 34314 to dev …Run Code Online (Sandbox Code Playgroud) 我们有两个的Windows Server,一个在2012 R2和其他2008 R2,它使用Apache HTTP服务器(httpd)2.4中的代理服务器/反向代理模式(的使用ProxyPass,ProxyPassReverse和虚拟主机配置)。两台服务器都使用来自 Apache Haus 的Apache 2.4.27 x64二进制构建。
我们有一些备份脚本在两台服务器上运行。他们停止所有服务(包括 Apache),然后进行备份并再次重新启动所有服务。
几年来(近 4 年),这些脚本运行良好。但是从 开始July 12, 2018,行为现在很奇怪。备份脚本正在执行它们的工作,停止所有服务,进行备份,但是现在,除 Apache 之外的所有服务都重新启动。
经过排查,发现Apache 2.4.27服务无法停止。使用服务控制台并尝试手动停止服务时,控制台显示“正在停止”并且没有任何反应。
所以我检查了正在运行的进程,看到一个httpd.exe进程正在运行。我试图终止该进程,但没有运气。
所以,我试过:
taskkill /im "httpd.exe" /f /t
Run Code Online (Sandbox Code Playgroud)
输出是:
ERROR: The process with PID 560 (child process of PID 480) could not be terminated.
Reason: There is no running instance of the task.
Run Code Online (Sandbox Code Playgroud)
所以我测试了pskill从 Sysinternals …
httpd service windows-server-2008-r2 windows-server-2012-r2 apache-2.4
我在 GCP 中有两个项目:
为什么这个 Pod 无法连接?想法?
谢谢。
google-compute-engine google-cloud-platform google-kubernetes-engine
背景:我的公司有私有 API,我们只向需要访问它的员工和供应商公开。话虽如此,其中有几个部分不需要登录即可查看,即状态检查和登录端点。
作为调试的一部分,现在我们在发生任何错误时都包含 AWS 实例 ID。以下是 API 在登录失败时可能返回的信息示例:
注意:这是伪数据,我们的实际 API 响应是不同的。
{
"status": {
"code": 400,
"name": "Bad Request",
"description": "This request is missing data or contains invalid information."
},
"error_data": {
"environment": "PRODUCTION",
"instance": "i-0b22b2d35aaaaaaaa",
"message": "Failed to login"
}
}
Run Code Online (Sandbox Code Playgroud)
过去,我们发现这对于跟踪 EC2 特定问题(通常是内存不足、磁盘空间不足和/或需要重新启动 nginx)非常有用。
我的问题:公开 AWS 实例 ID 是否会导致任何安全问题和/或是否有任何理由不这样做?
如果不应该公开实例 ID,如果有更好的方法来识别单个实例也会有所帮助吗?
使用命令行模式,您可以指定诸如“all,!ntpservers”之类的模式,但我不知道如何在剧本中指定它。我经常遇到必须在除服务器之外的所有机器上安装客户端的情况。
我在一台服务器上托管了 4 个域。我应该使用 4 个单独的 dkim 密钥还是一个用于所有密钥?
另外,就选择器而言,我是否需要使用 opendkim.conf 中指定的选择器,或者我可以/应该使用新密钥为每个域创建一个新的选择器吗?
我看到了这个CNAME记录的例子,但是不知道会返回什么IP,也找不到答案。
我正在寻找的 IPpc2.an.example.com和邮件服务器an.example.com
区域文件example.com:
example.com. IN SOA...
example.com. 1800 IN NS ns1.example.com
an.example.com. 1800 IN NS ns1.an.example.com
ns1.example.com. 1800 IN A 12.34.56.78
ns1.an.example.com. 1800 IN A 123.45.67.1
Run Code Online (Sandbox Code Playgroud)
区域文件an.example.com:
an.example.com. IN SOA...
an.example.com. IN NS ns1.an.example.com
ns1.an.example.com. 1800 IN A 123.45.67.1
an.example.com. MX 10 pc2.an.example.com
pc1.an.example.com. 1800 IN A 123.45.67.2
pc2.an.example.com 1800 IN A 23.45.67.89
pc2 CNAME pc1.an.example.com.
Run Code Online (Sandbox Code Playgroud)
那么哪些 IP 将返回给pc2邮件服务器?我的第一个想法是 CNAME 将被忽略,因为pc2它有一个完整 IP 的“A”记录,但我注意到末尾没有点pc2.an.example.com,也许这有影响,因为地址是相对的?
谢谢你的帮助!
我有一个多媒体网站,它让用户可以上传自己的媒体(视频、音乐)或嵌入来自 YouTube、Vimeo 等网站的媒体。
最近,正在宣布新的标题。我试图添加这个标题,但我相信我在某个地方犯了一个错误。
这就是我尝试添加此标题的方式;
Header always set Feature-Policy "vibrate 'self'; usermedia '*'; microphone 'none'; payment 'none'; sync-xhr 'self' mysiteURL.com"
Run Code Online (Sandbox Code Playgroud)
在下面得到这些错误;
Error with Feature-Policy header: Unrecognized feature: 'vibrate'.
(index):1 Error with Feature-Policy header: Unrecognized feature: 'usermedia'.
(index):1 Error with Feature-Policy header: Unrecognized origin: 'mysiteURL.com'.
(index):1 Error with Feature-Policy header: Unrecognized feature: 'vibrate'.
(index):1 Error with Feature-Policy header: Unrecognized feature: 'usermedia'.
(index):1 Error with Feature-Policy header: Unrecognized origin: 'mysiteURL.com'.
Run Code Online (Sandbox Code Playgroud)
任何帮助将不胜感激!
Centos 6. 最近更新了ca-certificates后遇到了一些麻烦。我有最新版本的针对 centos 6 的 curl:
-bash-4.1$ curl -V -v
curl 7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.27.1 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
Protocols: tftp ftp telnet dict ldap ldaps http file https ftps scp sftp
Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz
Run Code Online (Sandbox Code Playgroud)
和 wget:
-bash-4.1$ wget -V -v
GNU Wget 1.12 built on linux-gnu.
+digest +ipv6 +nls +ntlm +opie +md5/openssl +https -gnutls +openssl
-iri
Wgetrc:
/etc/wgetrc (system)
Locale: /usr/share/locale
Compile: gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc"
-DLOCALEDIR="/usr/share/locale" -I. -I../lib -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions …Run Code Online (Sandbox Code Playgroud) apache-2.4 ×2
security ×2
amazon-ec2 ×1
ansible ×1
cname-record ×1
curl ×1
dhcp ×1
dnsmasq ×1
email-server ×1
http-headers ×1
httpd ×1
ip ×1
linux ×1
mx-record ×1
opendkim ×1
postfix ×1
resolve ×1
router ×1
service ×1
vmware-esxi ×1
vmware-vsan ×1
wget ×1