小编Bre*_*ail的帖子

如何获取Java.exe/jvm.dll的符号文件来分析崩溃核心转储文件?

我有一个在Websphere应用服务器上运行的Java应用程序.当我分析系统崩溃核心转储文件时,我得到一些这样的信息:

ERROR: Symbol file could not be found.  Defaulted to export symbols for J9THR23.dll 
Run Code Online (Sandbox Code Playgroud)

如何获取Java的符号文件?

提前致谢.

更多细节在这里:

*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for J9THR23.dll - 
*************************************************************************
***                                                                   ***
***                                                                   ***
***    Your debugger is not using the correct symbols                 ***
***                                                                   ***
***    In order for this command to work properly, your symbol path   ***
***    must point to .pdb files that have …
Run Code Online (Sandbox Code Playgroud)

java websphere coredump

5
推荐指数
2
解决办法
6778
查看次数

在64位Windows上发送ctrl-break到java进程,在32位上发送send信号

我经常使用sendignal工具用于WebSphere Application Server进程(server,launchClient,wsadmin等)以生成堆转储.但是,sendignal在64位计算机上不起作用.有没有人知道将ctrl-break发送到远程进程的替代方法?

更新: Bengt指出这与以下问题基本相同.所以,我想我的问题是:过去两年有没有人找到解决这个限制的方法?

我可以向Windows上的应用程序发送ctrl-C(SIGINT)吗?

java windows 64-bit websphere signals

5
推荐指数
1
解决办法
4010
查看次数

为什么Websphere不喜欢BIRT?

我试图开始将项目部署到Websphere,并且得到以下错误提示。(缩短)

ERROR org.springframework.web.context.ContextLoader - Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'birtView' defined in ServletContext resource [/WEB-INF/applicationContext.xml]: Cannot resolve reference to bean 'birtEngine' while setting bean property 'birtEngine'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'birtEngine': FactoryBean threw exception on object creation; nested exception is java.lang.RuntimeException: Could not start the Birt engine!
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'birtEngine': FactoryBean threw exception on object creation; nested exception is java.lang.RuntimeException: Could not start the Birt …
Run Code Online (Sandbox Code Playgroud)

websphere spring birt

5
推荐指数
1
解决办法
2801
查看次数

在WAS 7上部署时,OpenJPA不记录日志

我已将我的应用程序部署到WebSphere Application Server 7,它在应用程序服务器中使用默认的OpenJPA 1.2.2库,但是,我无法将其记录,我在persistence.xml中有这个

<?xml version="1.0" encoding="UTF-8"?>
<persistence version="1.0"
  xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/persistence    http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd">
<persistence-unit name="SvcsLogic" transaction-type="JTA">
   <provider>org.apache.openjpa.persistence.PersistenceProviderImpl</provider>
   <jta-data-source>jdbc/mydatasource</jta-data-source>
   <exclude-unlisted-classes>true</exclude-unlisted-classes>
   <properties>
   <property name="openjpa.log" value="log4j, DefaultLevel=TRACE" />
   <property name="openjpa.Log" value="log4j, DefaultLevel=TRACE" />

   <property name="openjpa.jdbc.SynchronizeMappings"
      value="buildSchema(SchemaAction='add',foreignKeys=true)" />
   </properties>
</persistence-unit>
</persistence>
Run Code Online (Sandbox Code Playgroud)

但是,它会忽略我希望它使用log4j进行日志记录的事实,即使我删除了log4j设置它也不会修改WAS'Logs and Trace中的日志记录通道.我已将它设置为记录所有内容以确保,但它不起作用.

JPA Logging上的WAS信息中心文档说,但是避免麻烦:如果在使用应用程序服务器提供的持久性提供程序的容器管理持久性单元中定义"openjpa.Log"属性,则将忽略该属性.在这种情况下,您必须使用应用程序服务器的标准跟踪规范.

这是否意味着我必须更改我的JPA实现才能使日志记录正常工作?如果是这样,这似乎相当草率.

websphere logging openjpa

4
推荐指数
1
解决办法
5043
查看次数

Websphere Application Server 6.1(本地化):覆盖控制台消息的区域设置

我用西班牙语安装了RAD 7.5(基于Eclipse Ganymede 3.4.0).我正在使用Websphere Application Server 6.1(西班牙语).

我遇到的问题是所有控制台消息都以西班牙语显示,但在我个人看来,翻译很差(特别是因为即使控制台错误也以西班牙语显示,很难找到有关确切错误消息的文档).

我想用原始语言(英语)启动IDE,我知道有一个命令行开关-nl en,放在程序快捷方式上的eclipse可执行路径旁边,用于此目的.但是我仍然将一些资源标签(例如" 任务 "标签)变成西班牙语(标签显示" Tareas "),服务器控制台仍然以西班牙语显示消息.

[更新:昨天我工作的客户,改变了我的电脑以获得更强大的功能,并且不再发生未翻译的标签问题(新PC有Windows 7,前一个是XP,也许就是这样)]

我的问题是:有谁知道我怎么能用英语显示100%的WAS控制台消息,覆盖在设置时指定的语言环境?是否有一些命令行开关用于获取此功能?有没有办法编辑WAS配置文件来实现这一目标?

注意:由于我的计算机有一些限制,无法重新安装RAD和WAS.

提前致谢.

websphere command-line internationalization optional-parameters websphere-6.1

4
推荐指数
1
解决办法
5448
查看次数

在嵌入模式下使用openejb时找不到java:comp/env

作为openejb文件decalres

坚不可摧的规则.当事情不起作用时,一遍又一遍地阅读这些.

  1. java:comp/env是规范定义的命名空间,用于查找任何容器管理的资源
  2. java:comp/env默认为空
  3. java:comp/env在运行时java是只读的:通过xml或注释声明对容器管理资源的引用来填充comp/env

我在嵌入模式下使用openejb,DI工作正常,但我想在pojo中查找使用标准jndi查找作为ctx.lookup("java:comp/env/DS")获取对我的数据源的引用我试图通过无状态ejb中的xml和@Resource声明资源,以测试是否填充了env子上下文但我不知道为什么从未创建env子上下文... plz help

ejb jndi java-ee openejb

2
推荐指数
1
解决办法
1934
查看次数

WTRN0037W: 事务服务在 xa_recover 操作中遇到错误

我正在使用 WSA 8.5 、JDK 6、JDBC 11。我收到 XAException。我已按照其他帖子的建议设置了授予权限,但没有解决我的问题。

你能帮忙吗?此问题在负载测试下创建巨大的日志文件并导致应用程序挂起。

我在 SystemOut.log 中收到以下错误

[11/19/15 18:02:41:029 IST] 0000003d WSRdbXaResour E   DSRA0304E:  XAException occurred. XAException contents and details are: The cause is               : null.
[11/19/15 18:02:41:030 IST] 0000003d WSRdbXaResour E   DSRA0302E:  XAException occurred.  Error code is: XAER_RMERR (-3).  Exception is: <null>
[11/19/15 18:02:41:030 IST] 0000003d XARminst      E   WTRN0037W: The transaction service encountered an error on an xa_recover operation. The resource was com.ibm.ws.rsadapter.spi.WSRdbXaResourceImpl@cc24166c. The error code was XAER_RMERR. The exception stack trace follows: javax.transaction.xa.XAException
        at …
Run Code Online (Sandbox Code Playgroud)

websphere

2
推荐指数
1
解决办法
7453
查看次数

WebSphere MQ 调用失败,代码为“2”(“MQCC_FAILED”),原因为“2063”(“MQRC_SECURITY_ERROR”)

我是 WAS 7 和 Webshpere MQ 6,用于 Java 中的 JMS 应用程序。我在连接到队列时遇到此错误。com.ibm.msg.client.jms.DetailedJMSSecurityException:JMSWMQ0018:无法使用连接模式“客户端”和主机名“172.21.136.72”连接到队列管理器“Test_QManager”。检查队列管理器是否已启动,如果在客户端模式下运行,请检查是否有侦听器正在运行。请参阅链接的异常以获取更多信息。

引起原因:com.ibm.mq.MQException:JMSCMQ0001:WebSphere MQ 调用失败,代码为“2”(“MQCC_FAILED”),原因为“2063”(“MQRC_SECURITY_ERROR”)。请任何帮助。

websphere spring-jms ibm-mq

1
推荐指数
1
解决办法
1万
查看次数

WebSphere中的Apache配置

我的原始问题现在已经过编辑以避免混淆:

我在同一台机器上配置了Web服务器(Apache)和应用程序服务器配置文件.

1)生成插件,传播它并验证plugin-cfg.xml 2)安装DefaultApplication.ear(snoop)以测试连接3)检查应用服务器和已安装应用程序的虚拟主机4)确保端口号不重复5)重启应用服务器和apache

当我尝试点击URL来测试snoop时,没有运气.

http://xx.xx.xx.xxx:9080/snoop --> This is now WORKING, bit not port 80

http://xx.xx.xx.xxx/snoop
Not Found
The requested URL /snoop was not found on this server
Apache/2.2.15 (Red Hat) Server at xx.xx.xx.xxx Port 80
Run Code Online (Sandbox Code Playgroud)

你能告诉我什么是遗失的吗?

注意:我发现/ opt/IBM/WebSphere/plugIns下没有/ bin目录只有Conf和Logs目录可用.WAS版本是8.5.5.7

apache websphere

0
推荐指数
1
解决办法
658
查看次数